Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 06:43

1C 8.3 настройка сервера СЛК

Автор dddimmm, 03 окт 2020, 20:11

0 Пользователей и 1 гость просматривают эту тему.

dddimmm

Всем привет!
Помогите пожалуйста чайнику разобраться с настройками сервера СЛК. Ранее никогда не сталкивался с ним.

Имеем маленькую сеть, установленный ключ на 5 пользователей на одном из компьютеров(BELEOKS).
Есть необходимость переименовать компьютер на котором установлен ключ, но после переименования у пользователей в 1С пр  входе появляется ошибка:

нашел в режиме  Конфигуратора:
Общие - Подсистема - СЗК_СистемаЛицензированияКонфигурации
Общие - Общие формы - СЗК_СистемаЛицензированияКонфигурации


но уже битый час не могу найти эти настройки в режиме предприятия :dfbsdfbsdf:

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ УПРАВЛЕНИЯ ВИДИМОСТЬЮ

&НаКлиентеНаСервереБезКонтекста
// Процедура устанавливает значения по умолчанию полей ввода и управляет их видимостью.
Процедура УстановитьВидимость(Форма, ВидСвязиИзменен = Ложь)

Элементы = Форма.Элементы;

Элементы.ГруппаАдресСервераСЛК.Видимость      = Не (Форма.ВариантСвязи = 2);
Элементы.ГруппаАдресСервераСЛК.ТолькоПросмотр = Не (Форма.ВариантСвязи = 1);

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ

&НаСервере
// Процедура устанавливает вариант связи в зависимости от значения константы СЗК_ПараметрыСвязи.
Процедура ПрочитатьПараметрыСвязи()

СтрокаПараметровСвязи = НаборКонстант.СЗК_ПараметрыСвязи;

ИмяАдресКомпьютера = ПолучитьНастройкуИзКонстанты("host=", СтрокаПараметровСвязи);
СетевойПорт        = ПолучитьНастройкуИзКонстанты("port=", СтрокаПараметровСвязи);

Если ПустаяСтрока(СтрокаПараметровСвязи) И ЭтоФайловыйВариантИБ Тогда
ВариантСвязи = 2;
ИначеЕсли НРег(ИмяАдресКомпьютера) = "localhost" Тогда
ВариантСвязи = 0;
Иначе
ВариантСвязи = 1;
КонецЕсли;

КонецПроцедуры

&НаСервере
// Функция разбирает строковое значение константы и возвращает значение настройки.
//
// Параметры:
// НазваниеНастройки - название настройки, значение которой нужно вернуть из строковй константы СЗК_ПараметрыСвязи.
//
Функция ПолучитьНастройкуИзКонстанты(НазваниеНастройки, СтрокаПараметровСвязи)

ЗначениеНастройки = "";

ПозицияНачалаНастройки = Найти(НРег(СтрокаПараметровСвязи), НазваниеНастройки);
Если НЕ ПозицияНачалаНастройки = 0 Тогда
СтрокаНастройки = Сред(СтрокаПараметровСвязи, ПозицияНачалаНастройки, СтрДлина(СтрокаПараметровСвязи) - ПозицияНачалаНастройки + 1);
ПозицияКонцаНастройки = Найти(СтрокаНастройки, ";");
ЗначениеНастройки = Сред(СтрокаНастройки, СтрДлина(НазваниеНастройки) + 1, ПозицияКонцаНастройки - СтрДлина(НазваниеНастройки) - 1);
КонецЕсли;

Возврат ЗначениеНастройки;

КонецФункции

&НаКлиенте
// Процедура сброса параметров связи при изменении вида связи с сервером лицензий.
//
Процедура СброситьПараметрыСвязи()

Если ВариантСвязи = 0 Тогда
ИмяАдресКомпьютера = "localhost";
СетевойПорт        = "9099";
ИначеЕсли ВариантСвязи = 1 Тогда
ИмяАдресКомпьютера = "";
Иначе
ИмяАдресКомпьютера = "";
СетевойПорт        = "";
КонецЕсли;

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

&НаСервере
// Процедура - обработчик события "ПриСозданииНаСервере" формы.
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ЭтоФайловыйВариантИБ = (Найти(СтрокаСоединенияИнформационнойБазы(), "File=") > 0);

Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(0, "Локально, на этом компьютере");
Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(1, "На другом компьютере сети");
Если ЭтоФайловыйВариантИБ Тогда
Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(2, "Индивидуально для каждого пользователя");
КонецЕсли;

ПрочитатьПараметрыСвязи();

УстановитьВидимость(ЭтаФорма);

КонецПроцедуры

&НаКлиенте
// Процедура - обработчик события "ПередЗаписью" формы.
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Если ВариантСвязи = 2 Тогда
НаборКонстант.СЗК_ПараметрыСвязи = "";
Иначе
НаборКонстант.СЗК_ПараметрыСвязи = "host=" + ИмяАдресКомпьютера + ";" + "port=" + СетевойПорт + ";";
КонецЕсли;

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ОБРАБОТЧИКИ СОБЫТИЙ ЭЛЕМЕНТОВ ФОРМЫ

&НаКлиенте
// Процедура - обработчик события "ПриИзменении" переключателя "ПереключательВариантСвязи".
Процедура ПереключательВариантСвязиПриИзменении(Элемент)

СброситьПараметрыСвязи();

УстановитьВидимость(ЭтаФорма);

КонецПроцедуры

DmitriyF

Цитата: dddimmm от 03 окт 2020, 20:11
Всем привет!
Помогите пожалуйста чайнику разобраться с настройками сервера СЛК. Ранее никогда не сталкивался с ним.

Имеем маленькую сеть, установленный ключ на 5 пользователей на одном из компьютеров(BELEOKS).
Есть необходимость переименовать компьютер на котором установлен ключ, но после переименования у пользователей в 1С пр  входе появляется ошибка:

нашел в режиме  Конфигуратора:
Общие - Подсистема - СЗК_СистемаЛицензированияКонфигурации
Общие - Общие формы - СЗК_СистемаЛицензированияКонфигурации


но уже битый час не могу найти эти настройки в режиме предприятия :dfbsdfbsdf:

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ УПРАВЛЕНИЯ ВИДИМОСТЬЮ

&НаКлиентеНаСервереБезКонтекста
// Процедура устанавливает значения по умолчанию полей ввода и управляет их видимостью.
Процедура УстановитьВидимость(Форма, ВидСвязиИзменен = Ложь)

Элементы = Форма.Элементы;

Элементы.ГруппаАдресСервераСЛК.Видимость      = Не (Форма.ВариантСвязи = 2);
Элементы.ГруппаАдресСервераСЛК.ТолькоПросмотр = Не (Форма.ВариантСвязи = 1);

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ

&НаСервере
// Процедура устанавливает вариант связи в зависимости от значения константы СЗК_ПараметрыСвязи.
Процедура ПрочитатьПараметрыСвязи()

СтрокаПараметровСвязи = НаборКонстант.СЗК_ПараметрыСвязи;

ИмяАдресКомпьютера = ПолучитьНастройкуИзКонстанты("host=", СтрокаПараметровСвязи);
СетевойПорт        = ПолучитьНастройкуИзКонстанты("port=", СтрокаПараметровСвязи);

Если ПустаяСтрока(СтрокаПараметровСвязи) И ЭтоФайловыйВариантИБ Тогда
ВариантСвязи = 2;
ИначеЕсли НРег(ИмяАдресКомпьютера) = "localhost" Тогда
ВариантСвязи = 0;
Иначе
ВариантСвязи = 1;
КонецЕсли;

КонецПроцедуры

&НаСервере
// Функция разбирает строковое значение константы и возвращает значение настройки.
//
// Параметры:
// НазваниеНастройки - название настройки, значение которой нужно вернуть из строковй константы СЗК_ПараметрыСвязи.
//
Функция ПолучитьНастройкуИзКонстанты(НазваниеНастройки, СтрокаПараметровСвязи)

ЗначениеНастройки = "";

ПозицияНачалаНастройки = Найти(НРег(СтрокаПараметровСвязи), НазваниеНастройки);
Если НЕ ПозицияНачалаНастройки = 0 Тогда
СтрокаНастройки = Сред(СтрокаПараметровСвязи, ПозицияНачалаНастройки, СтрДлина(СтрокаПараметровСвязи) - ПозицияНачалаНастройки + 1);
ПозицияКонцаНастройки = Найти(СтрокаНастройки, ";");
ЗначениеНастройки = Сред(СтрокаНастройки, СтрДлина(НазваниеНастройки) + 1, ПозицияКонцаНастройки - СтрДлина(НазваниеНастройки) - 1);
КонецЕсли;

Возврат ЗначениеНастройки;

КонецФункции

&НаКлиенте
// Процедура сброса параметров связи при изменении вида связи с сервером лицензий.
//
Процедура СброситьПараметрыСвязи()

Если ВариантСвязи = 0 Тогда
ИмяАдресКомпьютера = "localhost";
СетевойПорт        = "9099";
ИначеЕсли ВариантСвязи = 1 Тогда
ИмяАдресКомпьютера = "";
Иначе
ИмяАдресКомпьютера = "";
СетевойПорт        = "";
КонецЕсли;

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

&НаСервере
// Процедура - обработчик события "ПриСозданииНаСервере" формы.
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ЭтоФайловыйВариантИБ = (Найти(СтрокаСоединенияИнформационнойБазы(), "File=") > 0);

Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(0, "Локально, на этом компьютере");
Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(1, "На другом компьютере сети");
Если ЭтоФайловыйВариантИБ Тогда
Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(2, "Индивидуально для каждого пользователя");
КонецЕсли;

ПрочитатьПараметрыСвязи();

УстановитьВидимость(ЭтаФорма);

КонецПроцедуры

&НаКлиенте
// Процедура - обработчик события "ПередЗаписью" формы.
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Если ВариантСвязи = 2 Тогда
НаборКонстант.СЗК_ПараметрыСвязи = "";
Иначе
НаборКонстант.СЗК_ПараметрыСвязи = "host=" + ИмяАдресКомпьютера + ";" + "port=" + СетевойПорт + ";";
КонецЕсли;

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ОБРАБОТЧИКИ СОБЫТИЙ ЭЛЕМЕНТОВ ФОРМЫ

&НаКлиенте
// Процедура - обработчик события "ПриИзменении" переключателя "ПереключательВариантСвязи".
Процедура ПереключательВариантСвязиПриИзменении(Элемент)

СброситьПараметрыСвязи();

УстановитьВидимость(ЭтаФорма);

КонецПроцедуры

В режиме предприятия пропиши в настройках СЛК новое имя компа или IP адрес

Геннадий ОбьГЭС

Цитата: dddimmm от 03 окт 2020, 20:11
Всем привет!
Помогите пожалуйста чайнику разобраться с настройками сервера СЛК. Ранее никогда не сталкивался с ним.

Имеем маленькую сеть, установленный ключ на 5 пользователей на одном из компьютеров(BELEOKS).
Есть необходимость переименовать компьютер на котором установлен ключ, но после переименования у пользователей в 1С пр  входе появляется ошибка:

нашел в режиме  Конфигуратора:

в режиме  Конфигуратора ничего не настраивают (а разрабатывают - изменяют)

dddimmm

DmitriyF, Геннадий ОбьГЭС,
я не могу найти эту форму в режиме прездприятия, вот в чем проблема)
в конфигураторе нашел по ключевой фразе "лицензир" а где это форма спрятана в режиме предприятия?:dfbbdrfb:

Геннадий ОбьГЭС

Учет в ЖКХ -> Настройка программы (ЖКХ) -> Дополнительно -> Настройка параметров системы лицензирования
в пользовательском режиме

Сервер СЛК должен настроить продавец, этим продуктом нельзя пользоваться не купив, как минимум отраслевую техподдержку ИТС
Да, и смысла нет - без действующей лицензии не будет работать интеграция с ГИС ЖКХ

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск