Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Re: Выгрузка в XML  (Прочитано 3339 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
подскажите как в 1С 7.7 Сформировать запрос, по выборке всех "ОсновныхСредств"(справочник) где "источник финансирования"(реквизит) = "бюджет"


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Выгрузка в XML
« Ответ #1: 06 Май 2011, 08:54 »
пример с Мисты.РУ

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");
 СпрСотр.ИспользоватьРодителя(грпРаботающие);
 СпрСотр.ИспользоватьДату(РабочаяДата());
 СпрСотр.ВыбратьЭлементы();
 Пока СпрСотр.ПолучитьЭлемент()=1 Цикл

Если СпрСотр.Должность <> длжПлотник Тогда
 ....Продолжить; //этого сотрудника пропускаем, перейти в начало цикла
 КонецЕсли;

<действия с очередным элементом>

КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Re: Выгрузка в XML
« Ответ #2: 06 Май 2011, 08:57 »
Админы, переименуйте плиз тему на что нибудь логичное!
Тему разделил, название со старой темы осталось.
Сразу забыл переименовать, а теперь не могу...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Re: Re: Выгрузка в XML
« Ответ #3: 06 Май 2011, 09:31 »
ОсновныеСредства = СоздатьОбъект("Справочник.ОсновныеСредства"); 
   ОсновныеСредства.ИспользоватьДату
   ОсновныеСредства.ВыбратьЭлементы();
   Пока ОсновныеСредства.ПолучитьЭлемент() = 1 Цикл
   
         Если ОсновныеСредства.ИсточникПриобретения = Перечисление.КодВидаДеятельности.Бюджет тогда
             ТаблицаДанных.НоваяСтрока();                             
            ТаблицаДанных.Подразделение = ОсновныеСредства.ИсточникПриобретения;
         конецЕсли;
         
   КонецЦикла;   

не хочет циклиться, говорит что методо получитьЭлемент() = 0, может быть потому что справочник иерархический?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Re: Выгрузка в XML
« Ответ #4: 07 Май 2011, 00:53 »
ОсновныеСредства.ИспользоватьДату ?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 167
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal