Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Сен 2020, 04:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подключение внешней обработки  (Прочитано 184 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tserj4

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-13
  • Сайт: 
  • Профессия: Программист 1С
Добрый день.
Помогите разобраться, написана внешняя обработка, если ее открывать через файл, то отрабатывает нормально, когда пытаюсь подключить как внешнюю, то выдает ошибку "Метод объекта не обнаружен (ВыполнитьКоманду)".
Конфигурация Управление нашей фирмой, редакция 1.6 (1.6.21.124) (http://v8.1c.ru/small/)
Платформа 8.3.16.1224
База клиент серверная
в модуле формы вот такой код:
&НаСервере
Функция ВыпНаСервере();
     Дата1 = НачалоДня(ТекущаяДата());
   Дата2 = КонецДня(ТекущаяДата());
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОперацияПоПлатежнымКартам.Ссылка КАК Ссылка,
      |   ОперацияПоПлатежнымКартам.Комментарий КАК Комментарий
      |ИЗ
      |   Документ.ОперацияПоПлатежнымКартам КАК ОперацияПоПлатежнымКартам
      |ГДЕ
      |   ОперацияПоПлатежнымКартам.Дата МЕЖДУ &Дата1 И &Дата2";
   
   Запрос.УстановитьПараметр("Дата1", Дата1);
   Запрос.УстановитьПараметр("Дата2", Дата2);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если Не ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Комментарий) Тогда
         Док = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
         Док.Комментарий = "Распечатан чек";
         Док.Записать();

         Возврат ВыборкаДетальныеЗаписи.Ссылка;
         
      КонецЕсли;   
   КонецЦикла;
   
   
КонецФункции




&НаКлиенте
Процедура Вып(Команда) Экспорт
   СсылкаНаДокумент = ВыпНаСервере(); //Получаю ссылку
   НоваяФорма = ПолучитьФорму("Документ.ОперацияПоПлатежнымКартам.ФормаОбъекта", новый Структура("Ключ",СсылкаНаДокумент));   //СсылкаНаДокумент.ПолучитьФорму("ФормаДокумента");
  НоваяФорма.Открыть();
  НоваяФорма.НапечататьЧек(Команда);
  НоваяФорма.Закрыть();   
КонецПроцедуры


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1415
  • РЕПУТАЦИЯ: 210
  • КПД: 15%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Добрый день.
Помогите разобраться, написана внешняя обработка, если ее открывать через файл, то отрабатывает нормально, когда пытаюсь подключить как внешнюю, то выдает ошибку "Метод объекта не обнаружен (ВыполнитьКоманду)".
Конфигурация Управление нашей фирмой, редакция 1.6 (1.6.21.124) (http://v8.1c.ru/small/)
Платформа 8.3.16.1224
База клиент серверная
в модуле формы вот такой код:
&НаСервере
Функция ВыпНаСервере();
     Дата1 = НачалоДня(ТекущаяДата());
   Дата2 = КонецДня(ТекущаяДата());
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОперацияПоПлатежнымКартам.Ссылка КАК Ссылка,
      |   ОперацияПоПлатежнымКартам.Комментарий КАК Комментарий
      |ИЗ
      |   Документ.ОперацияПоПлатежнымКартам КАК ОперацияПоПлатежнымКартам
      |ГДЕ
      |   ОперацияПоПлатежнымКартам.Дата МЕЖДУ &Дата1 И &Дата2";
   
   Запрос.УстановитьПараметр("Дата1", Дата1);
   Запрос.УстановитьПараметр("Дата2", Дата2);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если Не ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Комментарий) Тогда
         Док = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
         Док.Комментарий = "Распечатан чек";
         Док.Записать();

         Возврат ВыборкаДетальныеЗаписи.Ссылка;
         
      КонецЕсли;   
   КонецЦикла;
   
   
КонецФункции




&НаКлиенте
Процедура Вып(Команда) Экспорт
   СсылкаНаДокумент = ВыпНаСервере(); //Получаю ссылку
   НоваяФорма = ПолучитьФорму("Документ.ОперацияПоПлатежнымКартам.ФормаОбъекта", новый Структура("Ключ",СсылкаНаДокумент));   //СсылкаНаДокумент.ПолучитьФорму("ФормаДокумента");
  НоваяФорма.Открыть();
  НоваяФорма.НапечататьЧек(Команда);
  НоваяФорма.Закрыть();   
КонецПроцедуры
Следует привести не код модуля формы, а код модуля обработки. Ошибка там.

Оффлайн tserj4

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-13
  • Сайт: 
  • Профессия: Программист 1С
Код модуля обработки

Функция СведенияОВнешнейОбработке() Экспорт
   
   ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("1.1.1.1");
   ПараметрыРегистрации.Информация = НСтр("ru = 'Печать чека по эквайрингу'");
   ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
   ПараметрыРегистрации.Версия = "1.0.0.0";
   ПараметрыРегистрации.БезопасныйРежим = Истина;

   Команда = ПараметрыРегистрации.Команды.Добавить();
   Команда.Представление = НСтр("ru = 'Печать чека по эквайрингу'");
   Команда.Идентификатор = "ПечатьЧекаПоЭквайрингу";
   Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
   Команда.ПоказыватьОповещение = Истина;
   Команда.Модификатор = "ПечатьЧекаПоЭквайрингу";
   
   
   Возврат ПараметрыРегистрации;
   
КонецФункции


Оффлайн IL2016

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
надо поставить флаг - Отладка - Останавливать по ошибке.
тогда точно найдется место где ошибка.
Использую учебную платформу 1С:Предприятие 8.3

Оффлайн АлександрВладимирович

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 32
  • КПД: 38%
  • Регистрация: 2018-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Функция СведенияОВнешнейОбработке() Экспорт
   
   //ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("1.1.1.1");
   ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
   
   ПараметрыРегистрации.Информация = НСтр("ru = 'Печать чека по эквайрингу'");
   ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
   ПараметрыРегистрации.Версия = "1.0.0.0";
   ПараметрыРегистрации.БезопасныйРежим = Истина;

   Команда = ПараметрыРегистрации.Команды.Добавить();
   Команда.Представление = НСтр("ru = 'Печать чека по эквайрингу'");
   Команда.Идентификатор = "ПечатьЧекаПоЭквайрингу";
   //Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
   Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();

   //Команда.ПоказыватьОповещение = Истина;
   Команда.ПоказыватьОповещение = Ложь;
   
   //Команда.Модификатор = "ПечатьЧекаПоЭквайрингу";
   
   
   Возврат ПараметрыРегистрации;
   
КонецФункции


Теги:
 

Печать этикеток из обработки "Печать этикеток" УПП 1.3

Автор EgorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1052
Последний ответ 23 Авг 2019, 05:56
от Egor
Изменение дополнительных реквизитов справочника при помощи обработки "Групповое изменение реквизито"

Автор arch_vectorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3385
Последний ответ 22 Дек 2018, 10:48
от alex0402
Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 8487
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4461
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 828
Последний ответ 24 Авг 2017, 10:43
от Golickoff

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 382
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal