Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в базу данных  (Прочитано 2954 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Здравствуйте! Помогите,пожалуйста,разобраться вот в чём: при выборе реквизита перечисления "УСЛУГА", "НАЗВАНИЕ ПОКАЗАТЕЛЯ" и "ПОКАЗАТЕЛЬ" отображаться не должны.Так происходит только при работе с формой при выборе "УСЛУГА", но записи в базу не происходит и когда вновь открываешь форму,то значение "УСЛУГА" стоит ,но и также отображаются НАЗВАНИЕ ПОКАЗАТЕЛЯ и ПОКАЗАТЕЛЬ
Вот текст модуля.Может что-то здесь не так(см.картинку)


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вам нужно обрабатывать событие ПриОткрытии() - выполняется на клиенте перед открытием формы и служит как раз для установки свойств элементов управления на форме.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
что-то не выходит

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
что-то исправьте.

если вы хотите чтоб вам помогли - подробнее пишите!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Показатель "вес" или "Коэффициент" имеет смысл только для товара и материала(реквизит "ВидНоменклатуры". (СПРАВОЧНИК "НОМЕНКЛАТУРА")). Для услуги данный показатель считаться не должен.(см.Конфигурацию")

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
я тоже сейчас прохожу курс "Введение в конфигурирование" ;)
я делал так:

Процедура УстановитьВидимость()
   
   ЭтоНеУслуга = НЕ (Объект.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Услуга);
   
   Элементы.НазваниеПоказателя.Видимость = ЭтоНеУслуга;
   Элементы.Показатель.Видимость = ЭтоНеУслуга;
   Элементы.БазоваяЕдиницаИзмерения.Видимость = ЭтоНеУслуга;
   Элементы.ЕдиницаХраненияОстатков.Видимость = ЭтоНеУслуга;
   Элементы.Весовой.Видимость = ЭтоНеУслуга;
   
КонецПроцедуры

Процедура УстановитьЗначениеПоказателя()

   Если Объект.Весовой Тогда
      
      НазваниеПоказателя = "Вес: ";
      Показатель = Объект.ЕдиницаХраненияОстатков.Вес;
      
   Иначе   
      
      НазваниеПоказателя = "Коэффициент: ";
      Показатель = Объект.ЕдиницаХраненияОстатков.Коэффициент;
      
   КонецЕсли;

КонецПроцедуры
 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
   УстановитьЗначениеПоказателя();
   
   УстановитьВидимость();
   
КонецПроцедуры

&НаКлиенте
Процедура ВесовойПриИзменении(Элемент)
   
   УстановитьЗначениеПоказателя();
   
КонецПроцедуры

&НаКлиенте
Процедура ЕдиницаХраненияОстатковПриИзменении(Элемент)
   
   УстановитьЗначениеПоказателя();
   
КонецПроцедуры

&НаКлиенте
Процедура ВидНоменклатурыПриИзменении(Элемент)
   
   УстановитьВидимость();
   
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
спасибо!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Может Вы подскажите тогда что означают реквизиты НАИМЕНОВАНИЕ, ВЕС, КОЭФФИЦИЕНТ в справочнике Единицы Измерения.Никак не могу понять.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Наименование - это то как единица измерения называется
Вес - для товара обладающего весом (мешок картошки). сколько весит данная единица товара (мешок) в базовых единицах (в граммах)
Коэффициент - соотношение между текущей (метр) и базовой единицей измерения (мм). в нашем случае коэффициент будет равен 1000 (в 1ом метре = 1000мм).
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7452
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3890
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2125
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7362
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6964
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal