Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 16:15

Ошибки при типовой синхронизации УТ и Розницы

Автор Дмитрий Джей, 03 сен 2020, 17:09

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий Джей

1. Возникают ошибки при синхронизации УТ и Розницы. Ошибка на стороне УТ(Данные получены) Версия УТ 11.4.11.93 версия Розницы 2.3.5.32
Текст ошибки:
Поле объекта не обнаружено (ВидРедактирования)
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(9747)}:         ИначеЕсли НЕ ЭтоПараметрДляОбъекта
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(15617)}:         ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(2323)}:         ПроизвестиЧтениеДанных(ЧтениеСообщения);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(6392)}:            ОбработкаОбменаДаннымиXML.ВыполнитьЗагрузкуДанных();
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(5961)}:            ПрочитатьСообщениеСИзменениямиДляУзла(СтруктураНастроекОбмена, СообщениеОбмена, , ТолькоПараметры);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(373)}:   ВыполнитьОбменДаннымиЧерезФайловыйРесурс(СтруктураНастроекОбмена, ТолькоПараметры);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(2983)}:         ВыполнитьДействиеОбменаДляУзлаИнформационнойБазы(Отказ, УзелИнформационнойБазы,
{Обработка.ВыполнениеОбменаДанными.МодульМенеджера(34)}:   ОбменДаннымиСервер.ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы(
{(1)}:Обработки.ВыполнениеОбменаДанными.ВыполнитьЗапускОбменаДанными(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(4797)}:   Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(768)}:      ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыПроцедуры);
{ОбщийМодуль.ДлительныеОперации.Модуль(759)}:   ВыполнитьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);

2. Возникают ошибки при синхронизации УТ и Розницы(уже другие базы). Ошибка на стороне Розницы(Данные получены) Версия УТ 11.4.12.91 версия Розницы 2.3.5.32
текст ошибки:
Поле объекта не обнаружено (ОбувнаяПродукция)
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(9987)}:         ИначеЕсли НЕ ЭтоПараметрДляОбъекта
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(15947)}:         ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(2353)}:         ПроизвестиЧтениеДанных(ЧтениеСообщения);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7353)}:            ОбработкаОбменаДаннымиXML.ВыполнитьЗагрузкуДанных();
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(6924)}:            ПрочитатьСообщениеСИзменениямиДляУзла(СтруктураНастроекОбмена, СообщениеОбмена, , ТолькоПараметры);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(381)}:   ВыполнитьОбменДаннымиЧерезФайловыйРесурс(СтруктураНастроекОбмена, ТолькоПараметры);
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(3892)}:         ВыполнитьДействиеОбменаДляУзлаИнформационнойБазы(Отказ, УзелИнформационнойБазы,
{Обработка.ВыполнениеОбменаДанными.МодульМенеджера(34)}:   ОбменДаннымиСервер.ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы(
{(1)}:Обработки.ВыполнениеОбменаДанными.ВыполнитьЗапускОбменаДанными(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(4883)}:   Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(1026)}:      ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(1016)}:      ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);

Как видно ошибки идентичные, только разные объекты. Помогите разобраться и понять в чем проблема. Возможно ли так что эта проблема на стороне 1С и самого релиза поставщика 1С.

Геннадий ОбьГЭС

Я бы обновил УТ11 и воспользовался способами обхода из баг-трекера
https://bugboard.v8.1c.ru/

Цитирую багтрекер УТ11
Ошибка 00-00310337

Код ошибки: 00-00310337
Код(ы) обращения: HL-177150
Статус: Исправлена в выпущенной версии
Зарегистрирована: 09.07.2020
Исправлена: "1С:Управление торговлей 11", версия 11.4.12.81

Описание:
При выполнении синхронизации данных по правилам конвертации дополнительные свойства объектов, установленные в обработчиках правил ПослеЗагрузки(), не передаются в обработчики событий ПриЗаписи(), ПередЗаписью() на этапе отложенного проведения документов.

Способ исправления:
Установка патча EF_00_00310337 от 21.07.2020, если он применим для вашей версии программы, выполнится автоматически (при включенной настройке "Загружать и устанавливать исправления (патчи) автоматически"). Если автозагрузка патчей отключена, то можно выполнить установку по инструкции: http://downloads.v8.1c.ru/content/Instruction/patch-installation.pdf
==============
Ошибка 00-00305356

Код ошибки: 00-00305356
Код(ы) обращения: HL-167243
Статус: Принята к исправлению
Зарегистрирована: 23.06.2020
Продукт: "1С:Управление торговлей 11"

Описание:
Ошибка при синхронизации через EnterpriseData между Управление товрговлей версии 10.3 и Клиентом ЭДО версии... при регистрации к обмену всего справочника Номенклатура:
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(10941)}: Значение не является значением объектного типа (УникальныйИдентификатор)
УникальныйИдентификатор = СсылкаНаИсточник.УникальныйИдентификатор();

Способ обхода:
Использовать режим выгрузки "При необходимости" (только те НСИ, которые используются в документах).
===========
Ошибка 00-00296322

Код ошибки: 00-00296322
Статус: Исправлена в выпущенной версии
Зарегистрирована: 13.05.2020
Исправлена: "1С:Управление торговлей 11", версия 11.4.12.61

Описание:
При загрузке выписки банка через ДиректБанк синхронизация проходит успешно, но документы не создаются.

Способ обхода:
Способы обхода:
1. Осуществлять загрузку платёжных поручений из файла выписки банка.
2. После каждой синхронизации с банком открывать загруженную выписку и нажимать на кнопку "Разобрать" (открыть карточку банковского счёта организации, перейти на закладку "Обмен с банком (включен)", перейти по гиперссылке напротив Сервис 1С:ДиректБанк (рекомендуется), откроется окно настроек обмена, нажать на кнопку "Открыть электронные документы" (она находится между кнопками "Записать" и "Получить настройки"), в открывшемся окне перейти к последней загруженной выписке банка (она будт в самом низу), открыть её, нажать на кнопку Разобрать)
===================
Ошибка 00-00291412

Код ошибки: 00-00291412
Код(ы) обращения: FR-571361
Статус: Исправлена в выпущенной версии
Зарегистрирована: 21.04.2020
Исправлена: "1С:Управление торговлей 11", версия 11.4.12.61

Описание:
При настройке синхронизации данных через универсальный формат в пассивном режиме после выбора файла с настройками EnterpriseData возникает ошибка:

В методе ПриЗавершенииПомещенияФайлаНастроекXDTOКорреспондента количество параметров 4. Ожидаемое количество - 2.
{ОбщийМодуль.ФайловаяСистемаСлужебныйКлиент.Модуль(106)}: ВыполнитьОбработкуОповещения(ПараметрыОбработкиРезультата.ОбработчикЗавершения, ПомещенныеФайлы);

по причине:
В методе ПриЗавершенииПомещенияФайлаНастроекXDTOКорреспондента количество параметров 4. Ожидаемое количество - 2.

Способ исправления:
Обновить процедуру в Обработка.ПомощникСозданияОбменаДанными.Форма.НастройкаПодключения.Форма.Модуль:

&НаКлиенте
Процедура ПриЗавершенииПомещенияФайлаНастроекXDTOКорреспондента(ПомещенныйФайл, ДополнительныеПараметры) Экспорт

Если ПомещенныйФайл = Неопределено Тогда
Возврат;
КонецЕсли;

Результат = Новый Структура;
Результат.Вставить("Отказ", Ложь);
Результат.Вставить("СообщениеОбОшибке", "");

ЗаполнитьНастройкиXDTOКорреспондентаИзXMLНаСервере(ПомещенныйФайл.Хранение, Результат.Отказ, Результат.СообщениеОбОшибке);

Если Результат.Отказ Тогда
Если ПустаяСтрока(Результат.СообщениеОбОшибке) Тогда
Результат.СообщениеОбОшибке = НСтр("ru = 'Не удалось загрузить файл с настройками корреспондента.'");
КонецЕсли;
КонецЕсли;

ВыполнитьОбработкуОповещения(ДополнительныеПараметры.Оповещение, Результат);

КонецПроцедуры

======================
Ошибка 00-00282734

Код ошибки: 00-00282734
Статус: Исправлена в выпущенной версии
Зарегистрирована: 24.03.2020
Исправлена: "1С:Управление торговлей 11", версия 11.4.12.61

Описание:
При выполнении команды синхронизации Директ Банк не загружается банковская выписка.

======================

Код ошибки: 00-00277403
Код(ы) обращения: ED-206122
Статус: Планируется исправление в будущих версиях
Зарегистрирована: 26.02.2020
Исправлена: "1С:Управление торговлей 11"

Описание:
При синхронизации с сервисом ЭДО возникает ошибка "Возникла ошибка при чтении данных из файла...Поле объекта не обнаружено (Inn)"

====================



Цитата: Дмитрий Джей от 03 сен 2020, 17:09
1. Возникают ошибки при синхронизации УТ и Розницы. Ошибка на стороне УТ(Данные получены) Версия УТ 11.4.11.93 версия Розницы 2.3.5.32

DmitriyF

Цитата: Дмитрий Джей от 03 сен 2020, 17:09
1. Возникают ошибки при синхронизации УТ и Розницы. Ошибка на стороне УТ(Данные получены) Версия УТ 11.4.11.93 версия Розницы 2.3.5.32

2. Возникают ошибки при синхронизации УТ и Розницы(уже другие базы). Ошибка на стороне Розницы(Данные получены) Версия УТ 11.4.12.91 версия Розницы 2.3.5.32
текст ошибки:

Как видно ошибки идентичные, только разные объекты. Помогите разобраться и понять в чем проблема. Возможно ли так что эта проблема на стороне 1С и самого релиза поставщика 1С.
Либо обновляйте до последних релизов и пробуйте обмен, либо если проблема с обновлением то конвертация данных вам в помощь. В ней дел то на 15 минут.

Дмитрий Джей


В ней дел то на 15 минут.
[/quote]
Было бы интересно ее знать и понимать. Есть ли хорошие источники, литература, инструкции после прочтения которых, я смог бы решать подобные проблемы в течении 15 минут?:wacko:
Добавлено: 04 сен 2020, 09:39


Также заметил, что когда номенклатуру убираешь из регистрации синхронизация проходит.:angry:

DmitriyF

Цитата: Дмитрий Джей от 04 сен 2020, 09:36

В ней дел то на 15 минут.
Было бы интересно ее знать и понимать. Есть ли хорошие источники, литература, инструкции после прочтения которых, я смог бы решать подобные проблемы в течении 15 минут?:wacko:
Добавлено: 04 сен 2020, 09:39


Также заметил, что когда номенклатуру убираешь из регистрации синхронизация проходит.:angry:
[/quote]
Логично, обшивка то в ее реквизите

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск