Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку... печатная форма документа  (Прочитано 1655 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MasSseL

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте... зашел в тупик... дело вот в чем:
создал макет печатной формы с помощью конструктора... добавил область свою... она выводится... а загвоздка в следующем... мне необходимо в Параметр "ТекстДог" записать следующее... "владелец имущества "+ФИО+", именуемый...." где ФИО это значение реквизита документа.
делал...  Договор.Параметры.ТекстДог= "бла бла бла"; все работает.... (договор - это область)
помогите плиз...  :xfbnsdfb:
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну а так че?
 Договор.Параметры.ТекстДог = "владелец имущества "+ФИО+", именуемый....";

Оффлайн MasSseL

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-09
  • Сайт: 
  • Профессия: Ученик 1С
пишет что переменная ФИО не определена
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

Оффлайн MasSseL

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-09
  • Сайт: 
  • Профессия: Ученик 1С
вот что у меня записано:

Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Документы.ДоговорНаКвартиру.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДоговорНаКвартиру.ДатаДоговора,
   |   ДоговорНаКвартиру.Номер,
   |   ДоговорНаКвартиру.ФИО,
   |   ДоговорНаКвартиру.НомерДоговора,
   |   ДоговорНаКвартиру.АдресРегистрации,
   |   ДоговорНаКвартиру.Паспорт,
   |   ДоговорНаКвартиру.ДомашнийТелефон,
   |   ДоговорНаКвартиру.РабочийТелефон,
   |   ДоговорНаКвартиру.МобильныйТелефон
   |ИЗ
   |   Документ.ДоговорНаКвартиру КАК ДоговорНаКвартиру
   |ГДЕ
   |   ДоговорНаКвартиру.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   //Шапка = Макет.ПолучитьОбласть("Шапка");
   Договор = Макет.ПолучитьОбласть("Договор");
   ТабДок.Очистить();
   

   
   
   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;
      Договор.Параметры.ТекстДог= "владелец имущества"+ФИО;
      ТабДок.Вывести(ОбластьЗаголовок);
      Договор.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Договор);
//      Шапка.Параметры.Заполнить(Выборка);
//      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   //}}
КонецПроцедуры
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

Оффлайн MasSseL

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-09
  • Сайт: 
  • Профессия: Ученик 1С
эээх... всю бошку уже сломал.. и весь форум облазил((( а решения так и не достиг
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну раз в запросе выбираешь, тогда
Договор.Параметры.ТекстДог = "владелец имущества "+Выборка.ФИО+", именуемый....";

Оффлайн MasSseL

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-09
  • Сайт: 
  • Профессия: Ученик 1С
все заработало... спасибо!!!
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15922
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 625
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 704
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal