Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Авг 2020, 05:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Своя нумерация документа.  (Прочитано 261 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jane Smirnova

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-02-27
  • Сайт: 
Добрый день. УПП 1.3. Писала доработку для нумерации документа чтобы имело вид Префикс + ДДмм. номер.
Например КА2907.01,КА 2907.02. Единственное что не получается это убрать ведущий 0 после ".". Подскажите,пжл, как это сделать и где.
Должно получится КА2907.1,КА2907.2.


Оффлайн ef0din

  • ***
  • Сообщений: 196
  • РЕПУТАЦИЯ: 14
  • КПД: 7%
  • Регистрация: 2015-01-27
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. УПП 1.3. Писала доработку для нумерации документа чтобы имело вид Префикс + ДДмм. номер.
Например КА2907.01,КА 2907.02. Единственное что не получается это убрать ведущий 0 после ".". Подскажите,пжл, как это сделать и где.
Должно получится КА2907.1,КА2907.2.

Если все верно понял, - почему бы не формировать префикс ,как  "КА" + ДДмм, а периодичность нумерации сделать в пределах дня. Ну и длину номера необходимую подобрать.

Оффлайн Jane Smirnova

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-02-27
  • Сайт: 
Добрый день. УПП 1.3. Писала доработку для нумерации документа чтобы имело вид Префикс + ДДмм. номер.
Например КА2907.01,КА 2907.02. Единственное что не получается это убрать ведущий 0 после ".". Подскажите,пжл, как это сделать и где.
Должно получится КА2907.1,КА2907.2.

Если все верно понял, - почему бы не формировать префикс ,как  "КА" + ДДмм, а периодичность нумерации сделать в пределах дня. Ну и длину номера необходимую подобрать.

КА - я и ввела как префикс организации в справочнике. ДДмм добавила уже в процедуре "ДобавитьПрефиксОрганизации". потом он выводит порядковый номер.И периодичность день соблюдается. У нас больше 10 реализаций в день бывает.Соответственно количество символом уменьшила так что бы две цифры после "ДДмм." оставалось. и идет нумерация : 01,02,03....но вот приспичило чтобы незначащий 0 не выводился.А убрать его не выходит у меня.

Оффлайн antoneus

  • ****
  • Сообщений: 334
  • РЕПУТАЦИЯ: 86
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Префикс + Число(Номер)

где Номер - это "01", "02" и т.д.


Оффлайн Jane Smirnova

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-02-27
  • Сайт: 
Префикс + Число(Номер)

где Номер - это "01", "02" и т.д.



Префикс = ПрефиксОрганизации + ПрефиксДата + "." + Число(ДокументОбъект.Номер);

Не сработало так

Последний раз редактировалось: Jane Smirnova; 03 Авг 2020, 14:06

Оффлайн antoneus

  • ****
  • Сообщений: 334
  • РЕПУТАЦИЯ: 86
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Подробнее можно?

Оффлайн Jane Smirnova

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-02-27
  • Сайт: 
Подробнее можно?
Процедура ДобавитьПрефиксОрганизации_1(ДокументОбъект, Префикс) Экспорт
 
// Если в документе нет реквизита "Организация" или для организации не задан префикс,
// то используем пустой префикс, иначе используем префикс организации.
Префикс = "0";

Если ДокументОбъект.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
ПрефиксОрганизации = ПолучитьЗначениеРеквизита(ДокументОбъект.Организация, "Префикс");
Если ЗначениеЗаполнено(ПрефиксОрганизации) Тогда

ДатаГод = Формат(ДокументОбъект.Дата, "ДФ=ддММ");
        ПрефиксДата = Строка(ДатаГод);
Префикс = ПрефиксОрганизации + ПрефиксДата + ".";
// ---
Иначе
Префикс = ПрефиксОрганизации;
КонецЕсли;
КонецЕсли;

КонецПроцедуры

Оффлайн antoneus

  • ****
  • Сообщений: 334
  • РЕПУТАЦИЯ: 86
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Что это? Вижу какую-то отдельную процедуру, в которой переменной Префикс присваивается значение. А дальше что происходит?

Оффлайн Jane Smirnova

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-02-27
  • Сайт: 
Что это? Вижу какую-то отдельную процедуру, в которой переменной Префикс присваивается значение. А дальше что происходит?

Процедура ПриУстановкеНовогоНомераДляДокументов_1(Источник, СтандартнаяОбработка, Префикс) Экспорт
ДобавитьПрефиксОрганизации_1(Источник, Префикс);
ДобавитьПрефиксУзла(Префикс);

КонецПроцедуры


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6218
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 21669
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7664
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3562
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 10005
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
LexaK
30 Сообщений
ToryFree ToryFree
28 Сообщений
antoneus antoneus
27 Сообщений
alexandr_ll
26 Сообщений
DmitriyF DmitriyF
17 Сообщений
Алексей_1985_06
17 Сообщений
BuhRust
14 Сообщений
Алексей Рожков Алексей Рожков
12 Сообщений
judnikov
10 Сообщений

* Кто онлайн

  • Точка Гостей: 167
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal