Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Июл 2020, 06:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проведение документов в Управление торговлей 11  (Прочитано 258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн PLTBWH

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Запускается "Проведение документов", выбираются документы, указывается период и нажимается кнопка "Провести".
После чего выдается список документов, которые не получается провести.
Если развернуть информацию по каждому документу, то будет написано "Запись этого объекта возможна только из служебных механизмов".


Последний раз редактировалось: PLTBWH; 20 Июн 2020, 16:16


Оффлайн DmitriyF

  • *****
  • Сообщений: 1054
  • РЕПУТАЦИЯ: 77
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Запускается "Проведение документов", выбираются документы, указывается период и нажимается кнопка "Провести".
После чего выдается список документов, которые не получается провести.
Если развернуть информацию по каждому документу, то будет написано "Запись этого объекта возможна только из служебных механизмов".
А проблема то в чем?

Оффлайн PLTBWH

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Запускается "Проведение документов", выбираются документы, указывается период и нажимается кнопка "Провести".
После чего выдается список документов, которые не получается провести.
Если развернуть информацию по каждому документу, то будет написано "Запись этого объекта возможна только из служебных механизмов".
А проблема то в чем?
Вопрос в том, что за служебные механизмы и как провести эти документы?

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3845
  • РЕПУТАЦИЯ: 163
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Регистрация: 2015-03-12
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
Если найти и посмотреть код , когда выдаётся данное сообщение, то станет ясно, что 1С обеспечивает , чтобы запись данного документа происходила только при обновлении конфигурации или удалении документа

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

Если ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ОбновлениеИнформационнойБазы.ПроверитьОбъектОбработан(ЭтотОбъект);

Если Не ДополнительныеСвойства.Свойство("СинхронизацияКлючаСоЗначением")
И Не ПометкаУдаления Тогда

// Документ самостоятельно не используется.

Отказ = Истина;
ТекстОшибки = НСтр("ru = 'Запись этого объекта возможна только из служебных механизмов'");
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
ТекстОшибки,
ЭтотОбъект,
,
,
Отказ);

КонецЕсли;

КонецПроцедуры

Оффлайн PLTBWH

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Если найти и посмотреть код , когда выдаётся данное сообщение, то станет ясно, что 1С обеспечивает , чтобы запись данного документа происходила только при обновлении конфигурации или удалении документа

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

Если ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ОбновлениеИнформационнойБазы.ПроверитьОбъектОбработан(ЭтотОбъект);

Если Не ДополнительныеСвойства.Свойство("СинхронизацияКлючаСоЗначением")
И Не ПометкаУдаления Тогда

// Документ самостоятельно не используется.

Отказ = Истина;
ТекстОшибки = НСтр("ru = 'Запись этого объекта возможна только из служебных механизмов'");
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
ТекстОшибки,
ЭтотОбъект,
,
,
Отказ);

КонецЕсли;

КонецПроцедуры

Тогда появляется еще один вопрос, зачем их добавили в список выбора операции "Проведение документов", если их нельзя провести данным способом?

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3845
  • РЕПУТАЦИЯ: 163
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Регистрация: 2015-03-12
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
Тогда появляется еще один вопрос, зачем их добавили в список выбора операции "Проведение документов", если их нельзя провести данным способом?
Ошиблись
Версия-то какая?
Регулярно обновляю УТ11, но что-то не припоминаю там таких ошибок перепроведения

Оффлайн PLTBWH

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Тогда появляется еще один вопрос, зачем их добавили в список выбора операции "Проведение документов", если их нельзя провести данным способом?
Ошиблись
Версия-то какая?
Регулярно обновляю УТ11, но что-то не припоминаю там таких ошибок перепроведения

Версия конфигурации - 11.4.12.61.


Теги:
 

Размещение рекламы Форумы для специалистов: buhgalter-info.ru economist-info.ru sekretar-info.ru economist-info.ru Разделы: Наша профессия (1824) Кадровое делопроизводство (21366) Управление персоналом (1216) Трудовое законодательство (7361) Трудоустро

Автор YataРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2349
Последний ответ 28 Янв 2016, 13:32
от Yata
Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3354
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2650
Последний ответ 21 Сен 2017, 10:33
от Insider
1С "Управление аптекой"

Автор RegsterРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3710
Последний ответ 29 Апр 2010, 11:51
от Regster
Автоматизация системы оперативного, бухгалтерского учета и бюджетирования АО "Жигулевское пиво" с использованием "1С: ERP Управление предприятием 2"

Автор prominfoconsaltРаздел Блоги

Ответов: 0
Просмотров: 971
Последний ответ 24 Дек 2017, 21:36
от prominfoconsalt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
55 Сообщений
LexaK
41 Сообщений
DmitriyF DmitriyF
22 Сообщений
alexandr_ll
13 Сообщений
PLTBWH
13 Сообщений
antoneus antoneus
12 Сообщений
ToryFree ToryFree
9 Сообщений
Тари
9 Сообщений
BuhRust
9 Сообщений
alex0402 alex0402
8 Сообщений

* Кто онлайн

  • Точка Гостей: 410
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal