Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
04 Июл 2020, 17:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Событие не работает  (Прочитано 178 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kirill1579

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2020-05-26
  • Сайт: 
Добрый день, я пытаюсь вызвать на форме макет по нажатию на кнопку, но вот в чем проблема если я создаю процедуру на клиенте то получаю ошибку " Метод недоступен на тонком клиенте ТабДок.Вывести(Макет)", на сервере "Метод недоступен на сервере ТабДок.Показать()", что делать?
Код  " Метод недоступен на тонком клиенте ТабДок.Вывести(Макет)"
 &НаСервере
функция ПолучитьМакет()
   Возврат Справочники.Клиенты.ПолучитьМакет("Макет");
КонецФункции

&НаСервере
функция ПечатьНаСервере()
    ТабДок= новый ТабличныйДокумент;
    Макет = ПолучитьМакет();
    ТабДок.Вывести(Макет);
   ТабДок.Показать();
   
КонецФункции

&НаКлиенте
Процедура Печать(Команда)
    ТабДок= новый ТабличныйДокумент;
    Макет = ПолучитьМакет();
    ТабДок.Вывести(Макет);
   ТабДок.Показать();

КонецПроцедуры

Код "Метод недоступен на сервере ТабДок.Показать()"
&НаСервере
функция ПолучитьМакет()
   Возврат Справочники.Клиенты.ПолучитьМакет("Макет");
КонецФункции

&НаСервере
функция ПечатьНаСервере()
    ТабДок= новый ТабличныйДокумент;
    Макет = ПолучитьМакет();
    ТабДок.Вывести(Макет);
   ТабДок.Показать();
   
КонецФункции

&НаКлиенте
Процедура Печать(Команда)

ПечатьНаСервере()
КонецПроцедуры



Оффлайн antoneus

  • ****
  • Сообщений: 302
  • РЕПУТАЦИЯ: 78
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Ну очевидно же. Показать не работает на сервере, потому что ну кому там показывать-то? А Вывести там как раз работает.

&НаСервере
функция ПечатьНаСервере()
    ТабДок= новый ТабличныйДокумент;
    Макет = ПолучитьМакет();
    ТабДок.Вывести(Макет);
   Возврат ТабДок;
   
КонецФункции

&НаКлиенте
Процедура Печать(Команда)
   
   ПечатьНаСервере().Показать();

КонецПроцедуры


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2646
Последний ответ 21 Сен 2017, 10:33
от Insider
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 5365
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1413
Последний ответ 15 Дек 2017, 14:36
от alex0402
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5523
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5431
Последний ответ 20 Июн 2011, 11:14
от Zvezo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
LexaK
40 Сообщений
DmitriyF DmitriyF
28 Сообщений
alexandr_ll
14 Сообщений
PLTBWH
13 Сообщений
antoneus antoneus
10 Сообщений
ToryFree ToryFree
9 Сообщений
МЮлия
8 Сообщений
BuhRust
8 Сообщений
alex0402 alex0402
8 Сообщений

* Кто онлайн

  • Точка Гостей: 119
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal