Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 06:58

Проблемы с событием "ПриИзменении".

Автор ОдинОдинДевять, 24 мая 2020, 14:26

0 Пользователей и 1 гость просматривают эту тему.

ОдинОдинДевять



Добрый день, не могли бы вы мне помочь с одной проблемой, связанной с 1с?
У меня есть форма документа, в ней есть реквизит "Сотрудник", который
ссылается на соответствующий справочник. В справочнике "сотрудники" Id -
это номер элемента. Также есть реквизит "Id", он
ссылается на справочник "ID". В справочнике "id"
есть реквизиты ФИО и id.
Мне нужно сделать так, чтобы при изменении реквизита формы "Сотрудник"
менялось значение в реквизите "id".
Как это можно сделать и получится ли это в обратном порядке, т.е. при
изменении id менялся реквизит "Сотрудник"?
Если фотки не грузятся, то вот ссылка на диск: https://drive.google.com/open?id=11rbQ_miQgEHdqlpmDBpzUd_9NFkFijpY

antoneus

Справочник ID связан со справочником Сотрудники по коду? А почему в справочнике ID не сделать реквизит, который сразу будет являться ссылкой на элемент справочника Сотрудники? Или не сделать его вообще подчиненным?

ОдинОдинДевять

Цитата: ОдинОдинДевять от 24 мая 2020, 14:26


Добрый день, не могли бы вы мне помочь с одной проблемой, связанной с 1с?
У меня есть форма документа, в ней есть реквизит "Сотрудник", который
ссылается на соответствующий справочник. В справочнике "сотрудники" Id -
это номер элемента. Также есть реквизит "Id", он
ссылается на справочник "ID". В справочнике "id"
есть реквизиты ФИО и id.
Мне нужно сделать так, чтобы при изменении реквизита формы "Сотрудник"
менялось значение в реквизите "id".
Как это можно сделать и получится ли это в обратном порядке, т.е. при
изменении id менялся реквизит "Сотрудник"?
Если фотки не грузятся, то вот ссылка на диск: https://drive.google.com/open?id=11rbQ_miQgEHdqlpmDBpzUd_9NFkFijpY

antoneus

Я пока здесь вижу только проблемы с архитектурой, ну да ладно.

&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
    СотрудникПриИзмененииНаСервере()
КонецПроцедуры

&НаСервере
Процедура СотрудникПриИзмененииНаСервере()
    Объект.ID = Справочники.ID.НайтиПоРеквизиту("id", Объект.Сотрудник.Код)
КонецПроцедуры

&НаКлиенте
Процедура IDПриИзменении(Элемент)
    IDПриИзмененииНаСервере()
КонецПроцедуры

&НаСервере
Процедура IDПриИзмененииНаСервере()
    Объект.Сотрудник = Справочники.Сотрудники.НайтиПоКоду(Объект.ID.id)
КонецПроцедуры

Теги: код в 1с 

Похожие темы (5)

40576

Ответов: 2
Просмотров: 1461

29481

Ответов: 1
Просмотров: 2005

64473

Ответов: 2
Просмотров: 1550

62509

Ответов: 8
Просмотров: 1524

37388

Ответов: 0
Просмотров: 2215

Рейтинг@Mail.ru Rambler's Top100

Поиск