Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
05 Июн 2020, 07:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод Объекта не обнаружен  (Прочитано 79 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vany_siman

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2019-10-09
  • Сайт: 
  • Профессия: Ученик 1С
Помогите исправить, если буду делать на сервере, то ничего не будет происходить, а надо сделать, чтобы выводились сообщения пользователю о просроченных заявках
{МодульУправляемогоПриложения(3)}: Метод объекта не обнаружен (ОповеститьПользователя)
Оповещения.ОповеститьПользователя();
Модуль оповещения
&НаСервере
Процедура ОповеститьПользователя() Экспорт
МассивЗаявок = Новый Массив;
Пока Документы.ОформитьЗаявку.ПолучитьСсылку() Цикл
  МассивЗаявок.Добавить.Документы.ОформитьЗаявку.ПолучитьСсылку();
КонецЦикла;
Для Каждого ЭлементМассива Из МассивЗаявок Цикл
  Заявки = Документы.ОформитьЗаявку.Выбрать();
  Если Заявки.СтатусЗаявки = Перечисления.Статусы.Просрочена Тогда
     Сообщить("Заявка с таким номером просрочена" + Заявки);
  КонецЕсли;
КонецЦикла;
  КонецПроцедуры
Модуль управляемого приложения
&НаКлиенте
Процедура ПриНачалеРаботыСистемы()
Оповещения.ОповеститьПользователя();
КонецПроцедуры



Оффлайн antoneus

  • ****
  • Сообщений: 292
  • РЕПУТАЦИЯ: 74
  • КПД: 25%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Директивы (&НаКлиенте, &НаСервере и пр) в общих модулях не нужны, там контекст рулится галками. Чтобы ваша конструкция заработала, поставьте у модуля Оповещение галку Вызов сервера, а директивы выкиньте. И да, код в процедуре ОповеститьПользователя нерабочий, читайте хотя бы справку о том, что пишете.


Теги:
 

Для объекта конфигурации есть возможность выбирать способ редактирования ("в диалоге", "в списке", "обоими способами)" и выбора ("из формы", "быстрый выбор", "обоими способами")

Автор MusulmaninРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 156
Последний ответ 06 Апр 2020, 10:53
от Musulmanin
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4139
Последний ответ 09 Дек 2015, 19:33
от Oks
Ошибка "Поле объекта не обнаружено" при записи табл.части документа "ОперацияБух"

Автор Q37Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1601
Последний ответ 18 Авг 2018, 20:18
от Q37
Ошибка "Поле объекта не обнаружено"

Автор KSV67Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 7522
Последний ответ 29 Май 2014, 22:11
от KSV67
Общий реквизит или одинаковый реквизит для каждого объекта

Автор Соловьева Ольга_ИнтерсРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1808
Последний ответ 15 Июн 2015, 14:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
86 Сообщений
LexaK
66 Сообщений
antoneus antoneus
65 Сообщений
alexandr_ll
18 Сообщений
Funt432286
16 Сообщений
Funt Фунтиков
16 Сообщений
aleon1 aleon1
14 Сообщений
Анна Анисимова
13 Сообщений
skaut
12 Сообщений
strelok_stv
12 Сообщений

* Кто онлайн

  • Точка Гостей: 256
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal