Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:25

Оповещения,уведомления, сообщения пользователю

Автор vany_siman, 19 мая 2020, 22:44

0 Пользователей и 1 гость просматривают эту тему.

vany_siman

Разрабатываю конфигурацию по типу ИТС, только свою собственную для колледжа. Тема диплома такая просто,без вопросов лишних. Хочу сделать уведомления для мастеров и пользователей, о том, что заявки, которые находятся в Документе просрочены, для этого я уже сделал перечисления со статусами заявок и на списке формы видно, какие просрочены, какие в работе и так далее. Так вот, я хочу, чтобы пользователю при открытии системы сразу пришли уведомления об просроченных заявках, как это реализовать, я попробовал в модулю управляемого приложения код написать, но я неопытный в этом и туплю

&НаСервере
Процедура ПриНачалеРаботыСистемы()
   МассивЗаявок = Новый Массив;
   Пока Документы.ОформитьЗаявку.ПолучитьСсылку() Цикл
      МассивЗаявок.Добавить.Документы.ОформитьЗаявку.ПолучитьСсылку();
   КонецЦикла;
   Для Каждого ЭлементМассива Из МассивЗаявок Цикл
      Заявки = Документы.ОформитьЗаявку.Выбрать();
      Если Заявки.СтатусЗаявки = Перечисления.Статусы.Просрочена Тогда
         Сообщить("Заявка с таким номером просрочена" + Заявки);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры

TreeDogNight

Данный алгоритм вы должны перенести в экспортную процедуру общего модуля с включенным свойством "Вызов сервера" и вызвать её из обработчика события "ПриНачалеРаботыСистемы".
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

vany_siman

Произошла такая ошибка
{МодульУправляемогоПриложения(3)}: Метод объекта не обнаружен (ОповеститьПользователя)
   Оповещения.ОповеститьПользователя();
Вот скрин как сделал

LexaK

vany_siman,
попробуйте через обработчик ожидания!!!
в конфигураторе, в модуле приложения

Процедура ПриНачалеРаботыСистемы()

ПодключитьОбработчикОжидания("ПроверкаДокументов",60);

КонецПроцедуры

Процедура ПроверкаДокументов()Экспорт

//ОбщийМодульСервер.ЕстьПросроченныеДокументы() - это пример, напишите свою Серверную процедуру проверки просроченных документов
//возращаемые значения
//Истина - есть просроценные документы
//Ложь - просроченных документов нет

Если ОбщийМодульСервер.ЕстьПросроченныеДокументы() Тогда
//или показываем предупреждение
ПоказатьПредупреждение(,"Есть просроченные документы!", 30);
//и/или сразу открываем форму со списком просроченных документов
//ОткрытьФорму(...);
КонецЕсли;

КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск