Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
05 Июн 2020, 06:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Оповещения,уведомления, сообщения пользователю  (Прочитано 114 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vany_siman

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2019-10-09
  • Сайт: 
  • Профессия: Ученик 1С
Разрабатываю конфигурацию по типу ИТС, только свою собственную для колледжа. Тема диплома такая просто,без вопросов лишних. Хочу сделать уведомления для мастеров и пользователей, о том, что заявки, которые находятся в Документе просрочены, для этого я уже сделал перечисления со статусами заявок и на списке формы видно, какие просрочены, какие в работе и так далее. Так вот, я хочу, чтобы пользователю при открытии системы сразу пришли уведомления об просроченных заявках, как это реализовать, я попробовал в модулю управляемого приложения код написать, но я неопытный в этом и туплю

&НаСервере
Процедура ПриНачалеРаботыСистемы()
   МассивЗаявок = Новый Массив;
   Пока Документы.ОформитьЗаявку.ПолучитьСсылку() Цикл
      МассивЗаявок.Добавить.Документы.ОформитьЗаявку.ПолучитьСсылку();
   КонецЦикла;
   Для Каждого ЭлементМассива Из МассивЗаявок Цикл
      Заявки = Документы.ОформитьЗаявку.Выбрать();
      Если Заявки.СтатусЗаявки = Перечисления.Статусы.Просрочена Тогда
         Сообщить("Заявка с таким номером просрочена" + Заявки);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры


Оффлайн TreeDogNight

  • ***
  • Сообщений: 214
  • РЕПУТАЦИЯ: 28
  • КПД: 13%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: 
  • Профессия: Программист 1С
Данный алгоритм вы должны перенести в экспортную процедуру общего модуля с включенным свойством "Вызов сервера" и вызвать её из обработчика события "ПриНачалеРаботыСистемы".
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн vany_siman

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2019-10-09
  • Сайт: 
  • Профессия: Ученик 1С
Произошла такая ошибка
{МодульУправляемогоПриложения(3)}: Метод объекта не обнаружен (ОповеститьПользователя)
   Оповещения.ОповеститьПользователя();
Вот скрин как сделал

Оффлайн LexaK

  • *****
  • Сообщений: 2139
  • РЕПУТАЦИЯ: 629
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
vany_siman,
попробуйте через обработчик ожидания!!!
в конфигураторе, в модуле приложения
Процедура ПриНачалеРаботыСистемы()

ПодключитьОбработчикОжидания("ПроверкаДокументов",60);

КонецПроцедуры

Процедура ПроверкаДокументов()Экспорт

//ОбщийМодульСервер.ЕстьПросроченныеДокументы() - это пример, напишите свою Серверную процедуру проверки просроченных документов
//возращаемые значения
//Истина - есть просроценные документы
//Ложь - просроченных документов нет

Если ОбщийМодульСервер.ЕстьПросроченныеДокументы() Тогда
//или показываем предупреждение
ПоказатьПредупреждение(,"Есть просроченные документы!", 30);
//и/или сразу открываем форму со списком просроченных документов
//ОткрытьФорму(...);
КонецЕсли;

КонецПроцедуры
 
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)


Теги:
 

Значки "Новые сообщения" и "Нет новых сообщений".

Автор progmikonРаздел Предложения по работе форума

Ответов: 6
Просмотров: 5535
Последний ответ 07 Ноя 2010, 00:31
от progmikon
При загрузке выписки сообщение "поле объекта не обнаружено (дата сообщения) "

Автор ЭлиРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 7143
Последний ответ 02 Дек 2015, 14:41
от Эли
Состояние("текст сообщения"); - очень быстро пропадает.

Автор snoop82Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3791
Последний ответ 16 Июл 2015, 08:28
от cska-fanat-kz
Отключение системного сообщения "Нарушение прав доступа"

Автор Dima DdddРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 860
Последний ответ 23 Окт 2017, 15:58
от alex0402
Скрыть инфу о остатке на складе в сообщениях,или вообще скрыть сообщения

Автор David MalkhasyanРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 414
Последний ответ 25 Сен 2018, 13:57
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
86 Сообщений
LexaK
66 Сообщений
antoneus antoneus
65 Сообщений
alexandr_ll
18 Сообщений
Funt Фунтиков
16 Сообщений
Funt432286
16 Сообщений
aleon1 aleon1
14 Сообщений
Анна Анисимова
13 Сообщений
DmitriyF DmitriyF
12 Сообщений
skaut
12 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal