Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Группировка в отчёте и сумма.  (Прочитано 2171 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
У меня есть такая проблема:
В отчете выводится список сотрудников и рядом сумма с каждого выписанного ими товарного чека.
Сейчас отчёт выглядит так, как на рисунке выше, а надо было чтоб он выглядел так, как нижняя таблица.
Т.е. чтоб один и тот же сотрудник не выводился много раз, а группировался и напротив балы сумма всех выписанных им чеков.

Так это выгляди:



А вот процедура:

Процедура КнопкаСформироватьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
    |ТоварныйЧек.Менеджер КАК Менеджер,
    |ТоварныйЧек.СуммаДокумента КАК Сумма,
    |ТоварныйЧек.СуммаДокумента*0.05 КАК СуммаДокумента,
|ТоварныйЧек.Номер КАК Номер,
|ТоварныйЧек.Номер КАК Надпись
    |ИЗ
    |Документ.ТоварныйЧек КАК ТоварныйЧек
|ГДЕ
|ТоварныйЧек.Дата МЕЖДУ &ДатаНач И &ДатаКон
    |СГРУППИРОВАТЬ ПО
    |ТоварныйЧек.Менеджер,
    |ТоварныйЧек.Ссылка";
Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
Запрос.УстановитьПараметр("ДатаКон",ДатаКон);
Выборка = Запрос.Выполнить().Выбрать();
ТабДок = Новый ТабличныйДокумент;
Макет = Отчеты.НачислениеЗарплаты.ПолучитьМакет("Макет");
Область = Макет.ПолучитьОбласть("Заголовок");
Область.Параметры.Дата_Нач=ДатаНач;
Область.Параметры.Дата_Кон=ДатаКон;
ТабДок.Вывести(Область);
Область = Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(Область);
Н=0;
Пока Выборка.Следующий() Цикл
Область = Макет.ПолучитьОбласть("Строка");
Н = Н+1;
Область.Параметры.Номер = Н;
Область.Параметры.Сотрудник = Выборка.Менеджер;
Область.Параметры.Сумма = Выборка.СуммаДокумента;
Область.Параметры.Надпись = Выборка.Номер;
ТабДок.Вывести(Область);
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
  ТабДок.Показать()
 КонецПроцедуры

Помогите, что надо исправить? Очень нужно!


Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Процедура КнопкаСформироватьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
    |ТоварныйЧек.Менеджер КАК Менеджер,
    |ТоварныйЧек.СуммаДокумента КАК Сумма,
    |ТоварныйЧек.СуммаДокумента*0.05 КАК СуммаДокумента,
   |ТоварныйЧек.Номер КАК Номер,
   |ТоварныйЧек.Номер КАК Надпись
    |ИЗ
    |Документ.ТоварныйЧек КАК ТоварныйЧек
   |ГДЕ
   |ТоварныйЧек.Дата МЕЖДУ &ДатаНач И &ДатаКон
    |СГРУППИРОВАТЬ ПО
    |ТоварныйЧек.Менеджер,
    |ТоварныйЧек.Ссылка";
   Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
   Запрос.УстановитьПараметр("ДатаКон",ДатаКон);
   Выборка = Запрос.Выполнить().Выбрать();      
   ТабДок = Новый ТабличныйДокумент;      
   Макет = Отчеты.НачислениеЗарплаты.ПолучитьМакет("Макет");
   Область = Макет.ПолучитьОбласть("Заголовок");
   Область.Параметры.Дата_Нач=ДатаНач;
   Область.Параметры.Дата_Кон=ДатаКон;
   ТабДок.Вывести(Область);
   Область = Макет.ПолучитьОбласть("Шапка");   
   ТабДок.Вывести(Область);
   Н=0;
   Пока Выборка.Следующий() Цикл
      Область = Макет.ПолучитьОбласть("Строка");
      Н = Н+1;
      Область.Параметры.Номер = Н;
      Область.Параметры.Сотрудник = Выборка.Менеджер;
      Область.Параметры.Сумма = Выборка.СуммаДокумента;
      Область.Параметры.Надпись = Выборка.Номер;
      ТабДок.Вывести(Область);      
   КонецЦикла;   
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;   
   ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать()
 КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В конструкторе запросов лезьте на вкладку Итоги и укажите итог по ТоварныйЧек.Менеджер.
Далее при обходе результата запроса сперва выбираете верхний итоговый уровень по Менеджеру, а затем детальные записи по каждому документу...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 360
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1127
Последний ответ 13 Мар 2016, 00:55
от дфтын
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7332
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1165
Последний ответ 12 Апр 2016, 12:18
от Stanforeva
выбор параметра "Склад" в отчёте.

Автор The KAINРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 813
Последний ответ 22 Июн 2016, 08:11
от The KAIN

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal