Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 19:16

Прописать условие по заполнению реквизита документа в модуле другого документа

Автор SEMEN-YU, 28 фев 2020, 19:16

0 Пользователей и 1 гость просматривают эту тему.

SEMEN-YU

Помогите пожалуйста.
Есть документ ГТД по импорту. Он создаётся на основании Поступления товаров и услуг и Поступление Товаров Услуг В НТТ
Необходимо прописать условие, по которому Если в документе-основании не стоит флажок ОтражатьВБухгалтерскомУчете , то и в документе ГТД по импорту он тоже не стоит

Процедура ОбработкаЗаполнения(Основание)
    ПоступлениеТоваров    = (ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг"));
    ПоступлениеТоваровНТТ = (ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ"));

   
    Если ЗначениеЗаполнено(Основание) Тогда
        Если НЕ Основание.ОтражатьВБухгалтерскомУчете Тогда
            ОтражатьВБухгалтерскомУчете = Ложь;
           
        КонецЕсли;
    КонецЕсли;



Так же необходимо при том же условии скрыть доступность реквизита в ГТД по импорту. (с этим даже нет вариантов).
Заранее спасибо

ef0din

Цитата: SEMEN-YU от 28 фев 2020, 19:16
Помогите пожалуйста.
Есть документ ГТД по импорту. Он создаётся на основании Поступления товаров и услуг и Поступление Товаров Услуг В НТТ
Необходимо прописать условие, по которому Если в документе-основании не стоит флажок ОтражатьВБухгалтерскомУчете , то и в документе ГТД по импорту он тоже не стоит

Процедура ОбработкаЗаполнения(Основание)
    ПоступлениеТоваров    = (ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг"));
    ПоступлениеТоваровНТТ = (ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ"));

   
    Если ЗначениеЗаполнено(Основание) Тогда
        Если НЕ Основание.ОтражатьВБухгалтерскомУчете Тогда
            ОтражатьВБухгалтерскомУчете = Ложь;
           
        КонецЕсли;
    КонецЕсли;



Так же необходимо при том же условии скрыть доступность реквизита в ГТД по импорту. (с этим даже нет вариантов).
Заранее спасибо


Ну  Вы "ОтражатьВБухгалтерскомУчете"  устанавливаете в заполнении, а далее, при открытии формы проверяете условие ОтражатьВБухгалтерскомУчете = Ложь, и ставите в зависимости от него Ложь или Истину в "Элементы.'НужныйРеквизит'.Видимость"/"Элементы.'НужныйРеквизит'.Доступность".

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск