Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
04 Июл 2020, 18:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как пометить док на удаление из самой формы (программно)  (Прочитано 492 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dim3740

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
На форме документа размещен флажок Булево. Нужно, чтоб при его Истине, при закрытии формы документ помечался на удаление. Пока приходится проваливаться в журнал, и там помечать, что неудобно.


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1371
  • РЕПУТАЦИЯ: 208
  • КПД: 15%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
На форме документа размещен флажок Булево. Нужно, чтоб при его Истине, при закрытии формы документ помечался на удаление. Пока приходится проваливаться в журнал, и там помечать, что неудобно.
http://my1c-archive.narod.ru/knowhow/skpblock.html

Оффлайн dim3740

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Что это за ссылка? Кроме рекламного материала там ничего нет.

Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2) там же конфигурация лежит... поразбирайтесь в её коде.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн dim3740

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Прошу помощи. Я не программист. Делаю все методом проб и нужен конечный результат, т.к. скоро сводить баланс. Если есть вопросы по бухучету - рад буду помочь:).
Надо типа такого:
Процедура ПриЗакрытии() 

Если Удал=1 Тогда
Док.ПометитьНаУдаление();
КонецЕсли;

Док = Документ.ПолучитьОбъект();
Если Удал=1 Тогда
ПометкаУдаления = Истина;
КонецЕсли;     
Записать(РежимЗаписиДокумента.Запись);

КонецПроцедуры


Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(4) у Вас "клюшки" ИЛИ "снеговик" ?? :dfbsdfbsdf:
спрашиваете про 77, а пишете как в 8... :thwrt:
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн dim3740

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Вам "поговорить" или вы пришли на форум помогать? Я показал, что стараюсь найти ответ, а не просто получить на халяву.

Оффлайн alexandr_ll

  • *****
  • Сообщений: 1371
  • РЕПУТАЦИЯ: 208
  • КПД: 15%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Вам "поговорить" или вы пришли на форум помогать? Я показал, что стараюсь найти ответ, а не просто получить на халяву.
Дима, вы написали в теме Конфигурирование, программирование в "1С - Предприятие 7.7", я вам привел пример, как это решается в платформе 7.7.
Напишите четко платформу, конфигурацию и релиз.

Оффлайн dim3740

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Напишите четко платформу, конфигурацию и релиз.
7.70.027 Вашу конфу открыл, ниже передаланный и неработающий фрагмент.
Конфигурации нет, имеется всего один рукописный документ без проведения. В настоящее время, если я ошибся, то просто жду когда нужно сделать новый и заменяю старый. Это неудобно. Или приходится открывать журнал, выписывать какие ошибочные и в журнале помечать на удаление, что также плохо.

Перем ИсхДок;

Процедура ПриЗаписи()
Если ИсхДок.Выбран()=1 Тогда 
Если Удал=1 Тогда
ИсхДок.ПометкаУдаления();   
сообщить("1");
Иначе
ИсхДок.СнятьПометкуУдаления();
сообщить("2");
КонецЕсли;
//
// КопироватьДокумент(ИсхДок,Контекст);
ИсхДок.Записать();
// ИсхДок.Провести();
СтатусВозврата(0);
Форма.Закрыть(0);
Возврат;
КонецЕсли; ;

КонецПроцедуры
         

ИсхДок=СоздатьОбъект("Документ."+Вид()); 

Добавлено: 17 Фев 2020, 15:31

Пожалуйста, объясните:  а)в рукописной конфе сложно сделать\подсказать требуемое? или б)не интересно помогать, если задача нетиповая или в)я написал такую чушь, что бесполезно помогать?

Последний раз редактировалось: dim3740; 17 Фев 2020, 15:31. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
LexaK
40 Сообщений
DmitriyF DmitriyF
28 Сообщений
alexandr_ll
14 Сообщений
PLTBWH
13 Сообщений
antoneus antoneus
10 Сообщений
ToryFree ToryFree
9 Сообщений
bossko 844 bossko 844
8 Сообщений
BuhRust
8 Сообщений
МЮлия
8 Сообщений

* Кто онлайн

  • Точка Гостей: 136
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal