Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 сен 2021, 17:41

v7.7: Ошибка (агрегатного объекта не обнаружено)

Автор maksimiich, 15 янв 2020, 16:07

0 Пользователей и 1 гость просматривают эту тему.

maksimiich

нужна помощь.такая вот ошибка, в коде эта строка есть
Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
{Документ.Отпуск.Форма.Модуль(610)}: Поле агрегатного объекта не обнаружено (ФИОДатПад)

код:
    Document=МСWord.Documents.Open(СокрЛП(ШаблонПечати),,1);
   
    Document.Variables.Item("НомерПриказа").Value=СокрЛП(НомерДок);
   
    датаПриказа = формат(ДатаДок,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаПриказа").Value=СокрЛП(датаПриказа); 
   
    Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
    Document.Variables.Item("Должность").Value=СокрЛП(Сотрудник.ДолжностьДатПад);
   
    //КоличествоДней = ДатаКонца - ДатаНачала + 1;
    Document.Variables.Item("КоличествоДнейОтп").Value=СокрЛП(КоличествоДней)+ " ("+ Формат(КоличествоДней, "ЧП") + ")";
   
    датаНачОтп = формат(ДатаНачала,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаНОтп").Value=СокрЛП(датаНачОтп);
    датаКонОтп = формат(ДатаКонца,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаКОтп").Value=СокрЛП(датаКонОтп);
   
    Если ВидОтпуска.ТекущаяСтрока() = 1 Тогда
        ЗаПериод = Формат(ДатаН, "ДДДММГГГГ") + "-" + Формат(ДатаК, "ДДДММГГГГ");
        Document.Variables.Item("ПериодОтпуска").Value=СокрЛП(ЗаПериод);
    КонецЕсли;

alexandr_ll

Цитата: maksimiich от 15 янв 2020, 16:07
нужна помощь.такая вот ошибка, в коде эта строка есть
Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
{Документ.Отпуск.Форма.Модуль(610)}: Поле агрегатного объекта не обнаружено (ФИОДатПад)

код:
    Document=МСWord.Documents.Open(СокрЛП(ШаблонПечати),,1);
   
    Document.Variables.Item("НомерПриказа").Value=СокрЛП(НомерДок);
   
    датаПриказа = формат(ДатаДок,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаПриказа").Value=СокрЛП(датаПриказа); 
   
    Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
    Document.Variables.Item("Должность").Value=СокрЛП(Сотрудник.ДолжностьДатПад);
   
    //КоличествоДней = ДатаКонца - ДатаНачала + 1;
    Document.Variables.Item("КоличествоДнейОтп").Value=СокрЛП(КоличествоДней)+ " ("+ Формат(КоличествоДней, "ЧП") + ")";
   
    датаНачОтп = формат(ДатаНачала,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаНОтп").Value=СокрЛП(датаНачОтп);
    датаКонОтп = формат(ДатаКонца,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаКОтп").Value=СокрЛП(датаКонОтп);
   
    Если ВидОтпуска.ТекущаяСтрока() = 1 Тогда
        ЗаПериод = Формат(ДатаН, "ДДДММГГГГ") + "-" + Формат(ДатаК, "ДДДММГГГГ");
        Document.Variables.Item("ПериодОтпуска").Value=СокрЛП(ЗаПериод);
    КонецЕсли;
Проверьте наличие в справочнике "Сотрудники" реквизита "ФИОДатПад". Программа его не находит

maksimiich

Цитата: alexandr_ll от 16 янв 2020, 05:26
Цитата: maksimiich от 15 янв 2020, 16:07
нужна помощь.такая вот ошибка, в коде эта строка есть
Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
{Документ.Отпуск.Форма.Модуль(610)}: Поле агрегатного объекта не обнаружено (ФИОДатПад)

код:
    Document=МСWord.Documents.Open(СокрЛП(ШаблонПечати),,1);
   
    Document.Variables.Item("НомерПриказа").Value=СокрЛП(НомерДок);
   
    датаПриказа = формат(ДатаДок,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаПриказа").Value=СокрЛП(датаПриказа); 
   
    Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
    Document.Variables.Item("Должность").Value=СокрЛП(Сотрудник.ДолжностьДатПад);
   
    //КоличествоДней = ДатаКонца - ДатаНачала + 1;
    Document.Variables.Item("КоличествоДнейОтп").Value=СокрЛП(КоличествоДней)+ " ("+ Формат(КоличествоДней, "ЧП") + ")";
   
    датаНачОтп = формат(ДатаНачала,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаНОтп").Value=СокрЛП(датаНачОтп);
    датаКонОтп = формат(ДатаКонца,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаКОтп").Value=СокрЛП(датаКонОтп);
   
    Если ВидОтпуска.ТекущаяСтрока() = 1 Тогда
        ЗаПериод = Формат(ДатаН, "ДДДММГГГГ") + "-" + Формат(ДатаК, "ДДДММГГГГ");
        Document.Variables.Item("ПериодОтпуска").Value=СокрЛП(ЗаПериод);
    КонецЕсли;
Проверьте наличие в справочнике "Сотрудники" реквизита "ФИОДатПад". Программа его не находит
спасибо, помогло. ошибка исчезла, но при печати приказа выдает

ПРЕДОСТАВИТЬ:
                        Ошибка! Переменная документа не указана., Ошибка! Переменная документа не указана., часть трудового отпуска в количестве 12 (Двенадцать) календарных дней с 20 Января 2020 г. по 31 Января 2020 г. за период работы 01.01.2019-31.12.2019.
в чем сейчас может быть проблема?

alexandr_ll

Цитата: maksimiich от 16 янв 2020, 11:13
Цитата: alexandr_ll от 16 янв 2020, 05:26
Цитата: maksimiich от 15 янв 2020, 16:07
нужна помощь.такая вот ошибка, в коде эта строка есть
Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
{Документ.Отпуск.Форма.Модуль(610)}: Поле агрегатного объекта не обнаружено (ФИОДатПад)

код:
    Document=МСWord.Documents.Open(СокрЛП(ШаблонПечати),,1);
   
    Document.Variables.Item("НомерПриказа").Value=СокрЛП(НомерДок);
   
    датаПриказа = формат(ДатаДок,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаПриказа").Value=СокрЛП(датаПриказа); 
   
    Document.Variables.Item("Сотрудник").Value=СокрЛП(Сотрудник.ФИОДатПад);
    Document.Variables.Item("Должность").Value=СокрЛП(Сотрудник.ДолжностьДатПад);
   
    //КоличествоДней = ДатаКонца - ДатаНачала + 1;
    Document.Variables.Item("КоличествоДнейОтп").Value=СокрЛП(КоличествоДней)+ " ("+ Формат(КоличествоДней, "ЧП") + ")";
   
    датаНачОтп = формат(ДатаНачала,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаНОтп").Value=СокрЛП(датаНачОтп);
    датаКонОтп = формат(ДатаКонца,"Д (0)ДДММММГГГГ");
    Document.Variables.Item("ДатаКОтп").Value=СокрЛП(датаКонОтп);
   
    Если ВидОтпуска.ТекущаяСтрока() = 1 Тогда
        ЗаПериод = Формат(ДатаН, "ДДДММГГГГ") + "-" + Формат(ДатаК, "ДДДММГГГГ");
        Document.Variables.Item("ПериодОтпуска").Value=СокрЛП(ЗаПериод);
    КонецЕсли;
Проверьте наличие в справочнике "Сотрудники" реквизита "ФИОДатПад". Программа его не находит
спасибо, помогло. ошибка исчезла, но при печати приказа выдает

ПРЕДОСТАВИТЬ:
                        Ошибка! Переменная документа не указана., Ошибка! Переменная документа не указана., часть трудового отпуска в количестве 12 (Двенадцать) календарных дней с 20 Января 2020 г. по 31 Января 2020 г. за период работы 01.01.2019-31.12.2019.
в чем сейчас может быть проблема?
Проверьте правильность написания шаблона в ячейке макета печатной формы с текстом "ПРЕДОСТАВИТЬ".

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск