Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Янв 2020, 14:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вывести вес и объем в форме документа?  (Прочитано 131 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VID1234

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Привет. Ребята подскажите. Как поправить этот код, чтобы выводился результат этого цикла, в значение элемента формы документа. Отладчиком, цикл проходит, далее пишет объект суммаОбъема, следовательно и веса наверное тоже не найден. У меня в форме созданы 2 колонки, в которых прописывается значение единицы измерения в кг и м3 за 1 шт., по формуле я должен умножить значение каждой строки (товара) количество*на вес и количество*объем, а полученное вывести в форму, чтобы снизу было видно, хоть куда, даже в подвал, только не соображу как и еще чтобы менялся фон ячейки веса, если она не заполнена. Только пожалуйста по существу, а не так, ручками и прочее, не могу допетрить. реквизиты снизу я создал ВесТовара и ОбъемТовара, только там постоянно нули, ничего не меняется. Спасибо за помощь.
//VID(
      Объем1 = 0;
        Вес1 = 0;
        Для Каждого Строка Из Объект.Товары Цикл
        Объем1 = Объем1 + Строка.Количество * Строка.Объем;           
        Вес1 = Вес1 + Строка.Количество * Строка.Вес;   
    КонецЦикла;   
        Элементы.СуммаОбъема.Значение = Объем1;
        Элементы.СуммаВеса.Значение = Вес1;
   
       
           
Для каждого ОформлениеСтроки из ОформлениеСтроки Цикл
 Если ОформлениеСтроки.ДанныеСтроки.Номенклатура.ЕдиницаХраненияОстатков.Вес Тогда
  ЦветФона=Новый Цвет (255, 255, 255);
    Иначе
  ЦветФона=Новый Цвет (255, 147, 244);
КонецЕсли;
ОформлениеСтроки.ЦветФона=ЦветФона;
КонецЦикла;

       
        //VID)


Оффлайн wise

  • *****
  • Сообщений: 1021
  • РЕПУТАЦИЯ: 146
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) если СуммаОбъема - реквизит формы, то пишите ПРОСТО: СуммаОбъема = Объем1;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн VID1234

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-12-12
  • Сайт: 
  • Профессия: Ученик 1С
(0) если СуммаОбъема - реквизит формы, то пишите ПРОСТО: СуммаОбъема = Объем1;
Чет все равно ничего не появляется, также 0, хотя вес в колонке указан, количество меняю не реагирует


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5864
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 20569
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6319
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3019
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9520
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
42 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
40 Сообщений
alexandr_ll
29 Сообщений
VID1234
19 Сообщений
ef0din
17 Сообщений
DmitriyF DmitriyF
17 Сообщений
wise wise
15 Сообщений
alex0402 alex0402
15 Сообщений
Алексей_1985_06
14 Сообщений
BuhRust
13 Сообщений

* Кто онлайн

  • Точка Гостей: 770
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal