Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
03 Авг 2020, 14:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1с83 как обойти выборку запроса  (Прочитано 281 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн buketov.av

  • ***
  • Сообщений: 196
  • РЕПУТАЦИЯ: 8
  • КПД: 4%
  • смутные...
  • Регистрация: 2017-07-10
    • Skype: buketov.av
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день, Дорогие Форумчане!
На скриншоте результат выборки запроса.
Подскажите, пожалуйста, каким образом обойти ее правильно:
если НаправлениеВыпуска = "Выпуск продукции на склад", тогда надо искать в пределах одной спецификации одинаковые записи в полях ПодразделениеВыпуска и ЭтапПодразделение, если не найдено совпадений, тогда выполняется запись Выпуска и Спецификации в ТЧ на форме обработки, а если найдены соответствия, тогда переходим к следующей спецификации и выполняем подобные проверки.
Если же НаправлениеВыпуска = "Выпуск продукции в подразделение", тогда выполняем не одну, а две подобных проверки.

думал попробовать решить задачу таким образом

   ВыборкаВыпуск = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Выпуск");
    Пока ВыборкаВыпуск.Следующий() Цикл
        ВыборкаСпецификация = ВыборкаВыпуск.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Спецификация");
        Пока ВыборкаСпецификация.Следующий() Цикл
           
            ВыборкаПодразделениеВыпуска = ВыборкаСпецификация.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ПодразделениеВыпуска");
            Пока ВыборкаПодразделениеВыпуска.Следующий() Цикл
            КонецЦикла;
           
            ВыборкаПодразделениеПолучатель = ВыборкаСпецификация.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ПодразделениеПолучатель");
            Пока ВыборкаПодразделениеПолучатель.Следующий() Цикл
            КонецЦикла;
           
        КонецЦикла;
    КонецЦикла;

Последний раз редактировалось: buketov.av; 14 Янв 2020, 15:13


Оффлайн buketov.av

  • ***
  • Сообщений: 196
  • РЕПУТАЦИЯ: 8
  • КПД: 4%
  • смутные...
  • Регистрация: 2017-07-10
    • Skype: buketov.av
  • Сайт: 
  • Профессия: Разработчик 1С

но видимо такой код не поможет...
теперь думаю может всю выборку выгрузить в ТЗ и там делать некие действия, проверять построчно каждую спецификацию, так же имеем количество строк по каждой спецификации, так вот, попробовать может сделать так, КоличествоСтрокДоУдаления = Выборка.Количество(); и проверять на совпадения данные в колонках если совпадают, тогда КоличествоСТрокПослеУдаления = КоличествоСтрокДоУдаления - 1 и удалять строку ТЗ по этой спецификации и в итоге, если у нас КоличествоСтрокДоУдаления = КоличествоСТрокПослеУдаления, значит не было совпадений, а значит в Ресурсной спецификации нет такого такого этапа/участка/подразделения. которое указано в документе выпуска готовой продукции... мысли вслух..


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 17058
Последний ответ 14 Июн 2012, 17:44
от Alex1111
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7471
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 4975
Последний ответ 15 Июн 2017, 07:53
от mvk843
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1857
Последний ответ 29 Май 2017, 15:29
от alex0402
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 15649
Последний ответ 21 Апр 2011, 16:00
от Marta_Li

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
48 Сообщений
LexaK
40 Сообщений
ToryFree ToryFree
29 Сообщений
Алексей_1985_06
23 Сообщений
DmitriyF DmitriyF
20 Сообщений
alexandr_ll
20 Сообщений
antoneus antoneus
18 Сообщений
Тари
9 Сообщений
pavl_vs
8 Сообщений
Алексей Рожков Алексей Рожков
7 Сообщений

* Кто онлайн

  • Точка Гостей: 529
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal