Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
03 Авг 2020, 14:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как в УТ11.4 изменить Срок доставки в счете на оплату клиенту  (Прочитано 487 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VID1234

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Привет. подскажите, что и где нужно прописать, чтобы изменился срок действия счета на оплату, а то у меня указана там текущая дата (рисунок вопрос про срок доставки),
Если ТаблицаЭтапыОплаты.Количество() = 0 Тогда
        ДатаПлатежа = '00010101';
    ИначеЕсли ТаблицаЭтапыОплаты.Количество() = 1 Тогда
        ДатаПлатежа = ТаблицаЭтапыОплаты[0].ДатаПлатежа;
    Иначе
        ДатаПлатежа = ТаблицаЭтапыОплаты[ТаблицаЭтапыОплаты.Количество()-1].ДатаПлатежа;
    КонецЕсли;
   
    Если ЗначениеЗаполнено(ДатаПлатежа) Тогда
        СтруктураДанныхЗаголовок = Новый Структура;
        НадписьСрокДействия = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru='Счет действителен до %1.'"), Формат(ДатаПлатежа, "ДЛФ=D")) + " ";
        СтруктураДанныхЗаголовок.Вставить("СрокДействия", НадписьСрокДействия);
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхЗаголовок);
    КонецЕсли;
   
    ТабличныйДокумент.Вывести(ОбластьМакета);
, это код в модуле менеджера объекта, он отсылает на параметрВСтроку:
Функция ПодставитьПараметрыВСтроку(Знач ШаблонСтроки,
    Знач Параметр1, Знач Параметр2 = Неопределено, Знач Параметр3 = Неопределено,
    Знач Параметр4 = Неопределено, Знач Параметр5 = Неопределено, Знач Параметр6 = Неопределено,
    Знач Параметр7 = Неопределено, Знач Параметр8 = Неопределено, Знач Параметр9 = Неопределено) Экспорт
   
    ЕстьПараметрыСПроцентом = СтрНайти(Параметр1, "%")
        Или СтрНайти(Параметр2, "%")
        Или СтрНайти(Параметр3, "%")
        Или СтрНайти(Параметр4, "%")
        Или СтрНайти(Параметр5, "%")
        Или СтрНайти(Параметр6, "%")
        Или СтрНайти(Параметр7, "%")
        Или СтрНайти(Параметр8, "%")
        Или СтрНайти(Параметр9, "%");
       
    Если ЕстьПараметрыСПроцентом Тогда
        Возврат ПодставитьПараметрыСПроцентом(ШаблонСтроки, Параметр1,
            Параметр2, Параметр3, Параметр4, Параметр5, Параметр6, Параметр7, Параметр8, Параметр9);
    КонецЕсли;
   
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%1", Параметр1);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%2", Параметр2);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%3", Параметр3);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%4", Параметр4);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%5", Параметр5);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%6", Параметр6);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%7", Параметр7);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%8", Параметр8);
    ШаблонСтроки = СтрЗаменить(ШаблонСтроки, "%9", Параметр9);
    Возврат ШаблонСтроки;
   
КонецФункци


Оффлайн Сергей Зимин

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-07
  • Сайт: 
Так вопрос про срок доставки или время действия счета?
Срок доставки, насколько я понял, в УТ11 штатными средствами в счет не выводится. Только свою форму счета делать.
А срок действия счета прописывается в заказе клиента в поле "Оплата". Там можно указать дату и она и выведется в счет.


Теги: Ут11.4 
 

В 1с предприятие 8.3 управление торговлей 11.1 как изменить цену на несколько товаров с одним и тем же артиклем на последнюю введенную цену с помощью загрузки обработки или как это сделать в 1с с помощью программирования? прилагаю полный текст обработки

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 813
Последний ответ 11 Фев 2019, 15:15
от сергей123
Кнопка "Изменить"

Автор LanniaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 16
Просмотров: 3381
Последний ответ 03 Июн 2017, 01:50
от Dethmontt
Почему не грузиться в 1с новый производитель с тем же артикулом? Как изменить обработку что-бы артикул не проверялся а сразу заводился в справочник и суммировался с уже существующим товаром с выставлением последней цены при последней загрузки?

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 582
Последний ответ 14 Фев 2019, 11:19
от сергей123
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1847
Последний ответ 24 Янв 2018, 02:38
от Геннадий ОбьГЭС
Изменить иерархию отчета в настройках самого отчета(СКД)

Автор SamManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2259
Последний ответ 26 Апр 2015, 20:16
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
48 Сообщений
LexaK
40 Сообщений
ToryFree ToryFree
29 Сообщений
Алексей_1985_06
23 Сообщений
DmitriyF DmitriyF
20 Сообщений
alexandr_ll
20 Сообщений
antoneus antoneus
18 Сообщений
Тари
9 Сообщений
pavl_vs
8 Сообщений
Алексей Рожков Алексей Рожков
7 Сообщений

* Кто онлайн

  • Точка Гостей: 558
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal