Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 сен 2021, 18:12

Помогите начинающему падавану!!!

Автор Pablo151, 10 янв 2020, 11:49

0 Пользователей и 1 гость просматривают эту тему.

Pablo151

Задача! Необходимо чтобы при изменении Даты у проведенных Документов(периодических), очищался Номер Документа. В целом идея такая, если номер периодичный, то задаем границы периода для Ссылка.Дата, и если Объект.Дата в этот период не попадает, то очищаем номер! А код написать не могу) Спасибо, если кто откликнется

LexaK

в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
ответ Понравился? (в смысле пригодился?)

Pablo151

Цитата: LexaK от 10 янв 2020, 12:00
в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
Алексей спасибо! Но если не сложно, можете расписать "КакаяТоВашаПРоверка" подробней, допустим если периодичность "в пределах года"
Добавлено: 10 янв 2020, 12:17


Цитата: LexaK от 10 янв 2020, 12:00
в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
А если на форме Документа, в свойстве Дата "Процедура при изменении" возможно здесь реализовать?

wise

(0) в документе на закладке нумерация установите Периодичность: "В пределах года" и платформа ВСЁ сделает САМА :befhbt:
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Pablo151

Цитата: wise от 10 янв 2020, 12:59
(0) в документе на закладке нумерация установите Периодичность: "В пределах года" и платформа ВСЁ сделает САМА :befhbt:
Задача стоит такая, в Проведенных документах при изменении Даты, необходимо очистить Номер Документа. Периодичность у документов стоит. Проблема в том, что если бухгалтер меняет дату 30.10.19 на 10.01.20 и перепроводит документ, номер документ (условно 123) переносится на дату 10.01.20

wise

(4) в процедуре ПередЗаписьюНаСервере: Если ДатаГод(Объект.Дата)<> ДатаГод(ТекущийОбъект.Дата) Тогда
                                            //НИЗЯ!! B)
                                            Отказ = Истина;
                                        КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Pablo151

Цитата: wise от 10 янв 2020, 13:14
(4) в процедуре ПередЗаписьюНаСервере: Если ДатаГод(Объект.Дата)<> ДатаГод(ТекущийОбъект.Дата) Тогда
                                            //НИЗЯ!! B)
                                            Отказ = Истина;
                                        КонецЕсли;

Спасибо! Буду пробовать!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск