Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
03 Авг 2020, 15:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите начинающему падавану!!!  (Прочитано 422 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pablo151

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-10
  • Сайт: 
  • Профессия: Ученик 1С
Задача! Необходимо чтобы при изменении Даты у проведенных Документов(периодических), очищался Номер Документа. В целом идея такая, если номер периодичный, то задаем границы периода для Ссылка.Дата, и если Объект.Дата в этот период не попадает, то очищаем номер! А код написать не могу) Спасибо, если кто откликнется


Оффлайн LexaK

  • *****
  • Сообщений: 2215
  • РЕПУТАЦИЯ: 650
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн Pablo151

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-10
  • Сайт: 
  • Профессия: Ученик 1С
в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
Алексей спасибо! Но если не сложно, можете расписать "КакаяТоВашаПРоверка" подробней, допустим если периодичность "в пределах года"
Добавлено: 10 Янв 2020, 12:17

в модуле документа в процедуре: ПередЗаписью(...) проверяете значение Дата и перезаполняете номер документа
Если Дата - КакаяТоВашаПРоверка Тогда
    Номер = НовыйНомер;
КонецЕсли;
А если на форме Документа, в свойстве Дата "Процедура при изменении" возможно здесь реализовать?

Последний раз редактировалось: Pablo151; 10 Янв 2020, 12:17. Причина: Объединение сообщений

Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) в документе на закладке нумерация установите Периодичность: "В пределах года" и платформа ВСЁ сделает САМА :befhbt:
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Pablo151

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-10
  • Сайт: 
  • Профессия: Ученик 1С
(0) в документе на закладке нумерация установите Периодичность: "В пределах года" и платформа ВСЁ сделает САМА :befhbt:
Задача стоит такая, в Проведенных документах при изменении Даты, необходимо очистить Номер Документа. Периодичность у документов стоит. Проблема в том, что если бухгалтер меняет дату 30.10.19 на 10.01.20 и перепроводит документ, номер документ (условно 123) переносится на дату 10.01.20

Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(4) в процедуре ПередЗаписьюНаСервере:
Если ДатаГод(Объект.Дата)<> ДатаГод(ТекущийОбъект.Дата) Тогда
                                            //НИЗЯ!! B)
                                            Отказ = Истина;
                                        КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Pablo151

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-10
  • Сайт: 
  • Профессия: Ученик 1С
(4) в процедуре ПередЗаписьюНаСервере:
Если ДатаГод(Объект.Дата)<> ДатаГод(ТекущийОбъект.Дата) Тогда
                                            //НИЗЯ!! B)
                                            Отказ = Истина;
                                        КонецЕсли;

Спасибо! Буду пробовать!


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1050
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6754
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1230
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1529
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7168
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
48 Сообщений
LexaK
40 Сообщений
ToryFree ToryFree
29 Сообщений
Алексей_1985_06
23 Сообщений
DmitriyF DmitriyF
20 Сообщений
alexandr_ll
20 Сообщений
antoneus antoneus
18 Сообщений
Тари
9 Сообщений
pavl_vs
9 Сообщений
Алексей Рожков Алексей Рожков
7 Сообщений

* Кто онлайн

  • Точка Гостей: 490
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal