Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
03 Авг 2020, 14:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Код 1С, Помогите )  (Прочитано 285 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Сергей Беликов

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-01-10
  • Сайт: 
Не могу понять как найти максимум в заштрихованной области двумерного массива.
Задание 692 г - помогите пожалуйста, а то меня порешают на зачёте :bleh:

Вот так я создал массив, заполнил его рандомными числами и вывел :
ГСЧ = Новый ГенераторСлучайныхЧисел();
N = 0;
I = 0;
ВвестиЗначение ( N, "Введите значение" );
//ВвестиЗначение ( I, "Введите значение" );
I = N;
  М = Новый Массив(N, I);
 
  Для н = 0 по М.ВГраница() Цикл
     ВнутреннийМассив = М[н];
     Для к = 0 по ВнутреннийМассив.ВГраница() Цикл
        ВнутреннийМассив[к]=ГСЧ.СлучайноеЧисло(0, 200) - 100;
     КонецЦикла;
  КонецЦикла;
     Для Каждого ЭлементаМассива из М Цикл
    СтрокаВывода = "";
   Для Каждого ЭлементаМассиваВнут из ЭлементаМассива Цикл
     СтрокаВывода = СтрокаВывода + " " + ЭлементаМассиваВнут;
   КонецЦикла;
   Сообщить(СтрокаВывода);
  КонецЦикла;

Последний раз редактировалось: Сергей Беликов; 10 Янв 2020, 00:50


Оффлайн АлександрВладимирович

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 30
  • КПД: 39%
  • Регистрация: 2018-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: Код 1С, Помогите )
« Ответ #1: 11 Янв 2020, 20:43 »
	y = N - 1;

x0 = 0;
x1 = N - 1;

Результат = М[y][x0];

Пока x0 <= x1 Цикл

Для x = x0 По x1 Цикл

Если М[y][x] > Результат Тогда
Результат = М[y][x];
КонецЕсли;

КонецЦикла;

x0 = x0 + 1;
x1 = x1 - 1;

y = y - 1;

КонецЦикла;

Сообщить(Результат);


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1050
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6753
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1230
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1529
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7168
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
48 Сообщений
LexaK
40 Сообщений
ToryFree ToryFree
29 Сообщений
Алексей_1985_06
23 Сообщений
DmitriyF DmitriyF
20 Сообщений
alexandr_ll
20 Сообщений
antoneus antoneus
17 Сообщений
Тари
9 Сообщений
pavl_vs
8 Сообщений
bsn-chita
7 Сообщений

* Кто онлайн

  • Точка Гостей: 461
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal