Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 18:24

Помогите с выбором процедуры

Автор Алексей_1985_06, 08 янв 2020, 17:04

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Добрый день! Подскажите какую процедуру выбрать???
Есть документ "ПрисвоениеВоинскихЗваний" при проведении которого делается запись в ТЧ "ВоинскиеЗвания" справочника "ЛичныйСостав",  необходимо если такое звание у сотрудника уже записано, то выходило сообщение : "Внимание!!! Воинское звание уже было присвоено данному военнослужащему ранее". Сейчас все работает, но только это сообщение выходит только при нажатии на кнопку "ЗАПИСАТЬ" и "ПРОВЕСТИ" а вот при нажатии на кнопку "ПРОВЕСТИ И ЗАКРЫТЬ" сообщение не выходит, подскажите что нужно сделать чтоб сообщение было показано при нажатии и на кнопку "ПРОВЕСТИ И ЗАКРЫТЬ".
Конфигурация самописная УФ 8.3

ВОТ КОД:

&НаСервере
Процедура ИзменитьДанныеСправочникаНаСервере()
// Определяем какое звание записано сейчас в ТЧ "воинские звания" справочника "Личный Состав"
ЗаписаноеЗвание = ПолучитьСтрокуТЧнаСервере(Объект.ФамилияИмяОтчество, "ВоинскиеЗвания", "ВоинскоеЗвание", 100);

Если ЗаписаноеЗвание = Объект.ВоинскоеЗвание Тогда
Сообщить("Внимание!!! Воинское звание " + "(" + Объект.ВоинскоеЗвание + ")" + " уже было присвоено данному военнослужащему ранее") Иначе

ИзмСправочник = Объект.ФамилияИмяОтчество.ПолучитьОбъект(); // Получаем объект
НоваяСтрока =  ИзмСправочник.ВоинскиеЗвания.Добавить();  // Добавляем новую строку в ТЧ "ВоинскиеЗвания"
НоваяСтрока.ВоинскоеЗвание = Объект.ВоинскоеЗвание;
НоваяСтрока.ДатаПриказа = Объект.ДатаПриказа;
НоваяСтрока.НомерПриказа = Объект.НомерПриказа;
НоваяСтрока.ЧейПриказ = Объект.ЧейПриказ;
НоваяСтрока.Коррекция = ИмяПользователя() + " | " + Строка(Формат(ТекущаяДата(),"ДЛФ=ДДВ"));
ИзмСправочник.Записать(); // записываем изменения в информационную базу
КонецЕсли;
КонецПроцедуры


&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
ИзменитьДанныеСправочникаНаСервере();
КонецПроцедуры


temrmal

НИКАК!!! У вас при записать и закрыть закрывается форма, а сообщить() привязывается к форме.
Надо искать другие методы. Все зависит от того, с какой целью сообщение выходит, что потом делает пользователь.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск