Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: пересчитать цены в отчете производства за смену  (Прочитано 3605 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vseslovur

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-26
  • Сайт: 
  • Профессия: Программист 1С
Бухгалтерия 2.0 Платформа 8.2

 Ситуация такая:
 С начала года по текущий день в учетной политике стояла не та плановая цена. в документах отчет производства за смену, которых набралось достаточно, соответственно указана не та цена. В каждом документе около 50 наименований.

 Как массово пересчитать цену?

 В документе реализация товаров и услуг, есть кнопка "Изменить", которая вызывает обработку "ОбработкаТабличнойЧастиТовары". Там как раз есть позможность установить цену по типу.

 Попытался сделать такую же в документе "отчет производства за смену"


 В документе "Реализация Товаров и услуг" было так:

 Процедура КоманднаяПанельТоварыДействиеИзменить(Кнопка)

 // Получим контекст обработки
 ИзменениеТабличнойЧастиТовары = Обработки.ОбработкаТабличнойЧастиТовары.Создать();
 ФормаИзменениеТабличнойЧастиТовары = ИзменениеТабличнойЧастиТовары.ПолучитьФорму(,ЭтаФорма);

 //Установим реквизиты и переменные формы.
 ФормаИзменениеТабличнойЧастиТовары.ДокументОбъект = ЭтотОбъект;
 ФормаИзменениеТабличнойЧастиТовары.мФормаДокумента = ЭтаФорма;
 ФормаИзменениеТабличнойЧастиТовары.мЕстьНДС = УчитыватьНДС;
 ФормаИзменениеТабличнойЧастиТовары.мЕстьЦенаВРознице = Ложь;
 ФормаИзменениеТабличнойЧастиТовары.мСпособЗаполненияЦен = Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры;

 //Перенесем табличную часть
 ИзменениеТабличнойЧастиТовары.Товары.Загрузить(Товары.Выгрузить());

 // Открываем форму обработки
 ФормаИзменениеТабличнойЧастиТовары.Открыть();

 КонецПроцедуры




 При этом все работало.

 В Отчете производства за смену, сделал так:



 Процедура КоманднаяПанельТоварыДействиеИзменить(Кнопка)

 ИзменениеТабличнойЧастиТовары = Обработки.ОбработкаТабличнойЧастиТовары.Создать();
 ФормаИзменениеТабличнойЧастиТовары = ИзменениеТабличнойЧастиТовары.ПолучитьФорму(,ЭтаФорма);

 //Установим реквизиты и переменные формы.
 ФормаИзменениеТабличнойЧастиТовары.ДокументОбъект = ДокументОбъект;
 ФормаИзменениеТабличнойЧастиТовары.мФормаДокумента = ЭтаФорма;

 ФормаИзменениеТабличнойЧастиТовары.мЕстьНДС = Ложь;
 ФормаИзменениеТабличнойЧастиТовары.мЕстьЦенаВРознице = Ложь;
 ФормаИзменениеТабличнойЧастиТовары.мСпособЗаполненияЦен = Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры;

 //Перенесем табличную часть
 ИзменениеТабличнойЧастиТовары.Товары.Загрузить(Продукция.Выгрузить());

 // Открываем форму обработки
 ФормаИзменениеТабличнойЧастиТовары.Открыть();

 КонецПроцедуры



 Выдает ошибку "Не задан документ для обработки. Эта обработка может вызывается только из формы документа."

 Вот процедура, из модуля формы обработки:
 Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

 // Если не установлено значения объекта редактируемого документа,
 // то форму обработки открывать не нужно.
 Если ДокументОбъект = Неопределено Тогда

 Отказ = Истина;
 Предупреждение("Не задан документ для обработки!
 |Эта обработка может вызывается только из формы документа.", , Заголовок);
 Возврат;

 КонецЕсли;

 //Товары.ЗагрузитьКолонку(Товары.ВыгрузитьКолонку("НомерСтроки"), "НомерСтрокиДокумента");

 КонецПроцедуры // ПередОткрытием()

 Не пойму, почему в реализации оно работает, а в отчета производмтва нет(((

 Еще есть вариант написать внешнюю обработку. с двумя формами, в одной задается документ для обработки, затем открывается основная форма обработки, но опять та же ошибка((


Оффлайн cubase

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-05-21
  • Сайт: 
  • Профессия: Бухгалтер
"Групповая обработка справочников и документов" перкарсно справляется с такой задачей

Оффлайн Vseslovur

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-26
  • Сайт: 
  • Профессия: Программист 1С
"Групповая обработка справочников и документов" перкарсно справляется с такой задачей
Допустим. Отбираем документы и табличную часть Продукция, дальше что? Какое действие выбрать?


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 358
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1123
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 467
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7319
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1165
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 771
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal