Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 09:11

как изменить цвет строки в таблице значений?

Автор Роман Пестов, 23 дек 2019, 09:26

0 Пользователей и 1 гость просматривают эту тему.

Роман Пестов

Есть задание создать таблицу значений и окрашивать ячейку в красный цвет при определенном условии. я новичек и нас никак не обучают дали просто задание без объяснения. Я уже все написал только понять не могу как окрасить ячейку в нужный цвет вот код

&НаКлиенте
Процедура Команда1(Команда)
   Тз();
КонецПроцедуры


&НаСервере
Процедура Тз();

   я1Тов="товар1";
   я1Кол=1;
   я1Цен=50;
   
   
   я2Тов="товар2";
   я2Кол=2;
   я2Цен=10;
   
   я3Тов="товар3";
   я3Кол=1;
   я3Цен=200;
   
   я4Тов="товар4";
   я4Кол=3;
   я4Цен=300;
   
   я5Тов="товар5";
   я5Кол=10;
   я5Цен=50;
   
   НоваяСтрока1 = Реквизит1.Добавить();
   
   НоваяСтрока1.товар = я1Тов;
   НоваяСтрока1.количество = я1Кол;
   НоваяСтрока1.цена = я1Цен;
   НоваяСтрока1.сумма= я1Цен*я1Кол;
   //ОформлениеСтроки.НоваяСтрока1.сумма.ЦветФона = WebЦвета.Красный;
   
   НоваяСтрока2 = Реквизит1.Добавить();
   
   НоваяСтрока2.товар = я2Тов;
   НоваяСтрока2.количество = я2Кол;
   НоваяСтрока2.цена = я2Цен;
   НоваяСтрока2.сумма= я2Цен*я2Кол;
   
   НоваяСтрока3 = Реквизит1.Добавить();
   
   НоваяСтрока3.товар = я3Тов;
   НоваяСтрока3.количество = я3Кол;
   НоваяСтрока3.цена = я3Цен;
   НоваяСтрока3.сумма= я3Цен*я3Кол;
   
   НоваяСтрока4 = Реквизит1.Добавить();
   
   НоваяСтрока4.товар = я4Тов;
   НоваяСтрока4.количество = я4Кол;
   НоваяСтрока4.цена = я4Цен;
   НоваяСтрока4.сумма= я4Цен*я4Кол;
   
   НоваяСтрока5 = Реквизит1.Добавить();
   
   НоваяСтрока5.товар = я5Тов;
   НоваяСтрока5.количество = я5Кол;
   НоваяСтрока5.цена = я5Цен;
   НоваяСтрока5.сумма= я5Цен*я5Кол;
   
   СписокПриВыводеСтроки();// не могу понять какие данные отправлять на обработку
   
КонецПроцедуры

Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Если ДанныеСтроки.Цвет = "Красный" Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(255,128,128);
КонецЕсли;
КонецПроцедуры

Роман Пестов

я уже находил много способов в интернете, но я понять не могу какие элементы отправлять в процедуру для изменения цвета

LexaK

вот простенький пример, как расскрасить строки по условиям, в примере есть расскраска целой строки и одно поля.
откройте обработку в конфигураторе, в свойствах формы, за закладке Оформление, откройте конструктор УсловноеОформление, посмотрите и так же сделайте в своей форме (только имена своих полей/реквизитов подставьте)

так же условное оформление можно и программно задавать
(для начала конструктор более проще использовать) 
ответ Понравился? (в смысле пригодился?)

Роман Пестов

Цитата: LexaK от 23 дек 2019, 10:26
вот простенький пример, как расскрасить строки по условиям, в примере есть расскраска целой строки и одно поля.
откройте обработку в конфигураторе, в свойствах формы, за закладке Оформление, откройте конструктор УсловноеОформление, посмотрите и так же сделайте в своей форме (только имена своих полей/реквизитов подставьте)

так же условное оформление можно и программно задавать
(для начала конструктор более проще использовать) 
Но как сделать это программно я все равно не понял

LexaK

ЦитироватьНо как сделать это программно я все равно не понял
а зачем программно? вам же написали, для начинающих используйте конструктор! :befhbt:
ответ Понравился? (в смысле пригодился?)

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск