Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Мар 2021, 10:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сравнение значений в таблице значений  (Прочитано 561 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн АндрейМСХ

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-05-24
  • Сайт: 
  • Профессия: Ученик 1С
Друзья, подскажите пожалуйста. Есть две таблицы значений.
ТЗ1
Параметр1 Параметр2 Значение
Задача1   ТекГод     Выполнена
Задача1   ПредГод    Выполнена
Задача2   ТекГод     Не выполнена
..................................
ТЗ2
Параметр1 Параметр2  Код
Задача1   ТекГод     1
Задача1   ПредГод    2
Задача2   ТекГод     3
..................................
Нужно сравнить строки этих таблиц, и при условии если Параметр1 ТЗ1 = Параметр1 ТЗ2 И Параметр2 ТЗ1 = Параметр 2 ТЗ2  сообщить Значение и Код.


Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) перебирайте строки ТЗ1 и в цикле делайте поиск строк ТЗ2 по параметрам текущей строки ТЗ1.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн АндрейМСХ

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-05-24
  • Сайт: 
  • Профессия: Ученик 1С
(0) перебирайте строки ТЗ1 и в цикле делайте поиск строк ТЗ2 по параметрам текущей строки ТЗ1.
Пишу так
Для Каждого СтрокаТЗ1 из ТЗ1 Цикл
    Отбор = Новый Структура;
    Отбор.Вставить("Параметр1",ТЗ2.Параметр1);
    Отбор.Вставить("Параметр2",ТЗ2.Параметр1);
    МассивСтрок = ТЗ2.Найти(Отбор);
    Для Каждого Строка из МассивСтрок Цикл
        Сообщить(Строка.Значение);
     КонецЦикла;
КонецЦикла;

Где ошибки?

Оффлайн LexaK

  • *****
  • Сообщений: 2434
  • РЕПУТАЦИЯ: 749
  • КПД: 31%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
	лкОтбор = Новый Структура("Параметр1,Параметр2");
Для Каждого СтрокаТЗ1 из ТЗ1 Цикл
ЗаполнитьЗначенияСвойств(лкОтбор, СтрокаТЗ1);
МассивСтрок = ТЗ2.НайтиСтроки(лкОтбор);
    Для Каждого СтрокаТЗ2 из МассивСтрок Цикл
        Сообщить("ТЗ1; "
+ СтрокаТЗ1.Параметр1 + ", "
+ СтрокаТЗ1.Параметр2 + ", "
+ СтрокаТЗ1.Значение + ", Значение ТЗ2: "
+ Строка.Значение);
     КонецЦикла;
КонецЦикла;
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)


Теги:
 

Рассчитать значения в таблице "подвала"

Автор ТариРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 946
Последний ответ 17 Июн 2020, 17:26
от Тари
Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1049
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Как правильно сделать запрос и получить количество повторяющихся элементов в таблице (временная)?

Автор Владислав КлишинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3880
Последний ответ 18 Янв 2016, 13:38
от Дмитрий@
Нельзя обращаться к вложенной таблице через поле составного типа

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3435
Последний ответ 04 Авг 2015, 15:20
от ferrari314
Как Табличный документ (полученный Exсel) отобразить в Таблице УпрФормы

Автор leotomРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 8189
Последний ответ 02 Фев 2014, 23:27
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
104 Сообщений
antoneus antoneus
30 Сообщений
Алексей_1985_06
29 Сообщений
LexaK
24 Сообщений
BuhRust
18 Сообщений
ls600 ls600
17 Сообщений
kah
13 Сообщений
DNN
12 Сообщений
DmitriyF DmitriyF
10 Сообщений
Ивашка
9 Сообщений

* Кто онлайн

  • Точка Гостей: 141
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal