Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:42

Доступность формы для различных пользователей

Автор Алексей_1985_06, 24 ноя 2019, 13:42

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Доброго времени суток! Знающие люди подскажите, что не так в коде? Задача заключается в том, чтобы форма была доступна только для просмотра - для пользователей которые не создавали данный элемент. Т.е есть исполнитель (реквизит исполнитель = текущий пользователь) который может вносить коррективы в записи, а если данный элемент справочника открыл другой пользователь - то он может только просмотреть эти данные...

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Не ЗначениеЗаполнено(Объект.Исполнитель) Тогда
        //Исполнитель еще пустой, заполняем
    Объект.Исполнитель = ПользователиИнформационнойБазы.ТекущийПользователь();
    КонецЕсли;
   
    //добавляем проверку для доступность формы элемента справочника
    Если Объект.Исполнитель = ПользователиИнформационнойБазы.ТекущийПользователь() Тогда
        ЭтаФорма.Доступность = Истина;
    Иначе
        ЭтаФорма.Доступность = Ложь; 
    КонецЕсли;
КонецПроцедуры


При таком варианте - форма становится недоступной для любого пользователя, не пойму что не так?

wise

(0) для начала - в 7.7 НЕ взлетит... :P

скажите, КАКОЙ Тип значения у реквизита "Исполнитель" ?? B)
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Алексей_1985_06

Цитата: wise от 24 ноя 2019, 17:45
(0) для начала - в 7.7 НЕ взлетит... :P

скажите, КАКОЙ Тип значения у реквизита "Исполнитель" ?? B)

Не понял на счет 7.7 ????
Тип значения у реквизита "Исполнитель" строка.

MuI_I_Ika

У вас путаница с типами данных. Исполнитель у объекта это элемент справочника пользователи. А то что вы получаете из ПользователиИнформационнойБазы справочником пользователи не является.

Подсказка. Элемент справочника пользователи сидит в параметре сеанса ТекущийПользователь

MuI_I_Ika

Цитата: Алексей_1985_06 от 24 ноя 2019, 21:06Тип значения у реквизита "Исполнитель" строка.

Тем более если строка, то сравнивать его с не строкой неправильно.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск