Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2019, 11:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не удается получить данныес mysql  (Прочитано 362 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot488

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста, нужно затягивать в 1С данные с mysql, внешний источник данных подключил без проблем. В консоле запросов так же читаю данные без проблем. Через обработку прочитать данные не получается.

&НаСервере
Процедура ПоехалиНаСервере()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| fifo.id КАК id,
| fifo.datetime КАК datetime,
| fifo.src КАК src,
| fifo.dst КАК dst
|ИЗ
| ВнешнийИсточникДанных.Binotel.Таблица.fifo КАК fifo";
         
Результат = Запрос.Выполнить().Выгрузить();

Для Каждого ЭлементРезультата из Результат Цикл
    Попытка
        НовыйДокумент = Документы.РегистрацияЗвонковБинотел.СоздатьДокумент();
        НовыйДокумент.IdЗвонка      =  ЭлементРезультата.id;

        НовыйДокумент.Записать(РежимЗаписиДокумента.Запись);
           Исключение
       КонецПопытки;
КонецЦикла;



КонецПроцедуры



&НаКлиенте
Процедура Пуск(Команда)
ПоехалиНаСервере();
КонецПроцедуры


Оффлайн Каримдат

  • ****
  • Сообщений: 431
  • РЕПУТАЦИЯ: 42
  • КПД: 10%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: vk.com
  • Профессия: Ученик 1С
Может вместо символа & нужно # указать?

Оффлайн Dethmontt

  • Денис
  • *****
  • Сообщений: 2864
  • РЕПУТАЦИЯ: 550
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Через обработку прочитать данные не получается.

А ошибку озвучить нельзя?
(Возможно нужно инициализировать подключение к внешнему источнику или в обработке установить безопасный режим в ЛОЖЬ)
МАЛО ПОДРОБНОСТЕЙ!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 6900
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2113
Последний ответ 02 Дек 2016, 12:58
от Jalib
Как в ВПФ справочника получить реквизит другого справочника

Автор Вадим ФРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 587
Последний ответ 26 Июн 2018, 14:09
от Вадим Ф
Получить реквизиты документа из другого документа

Автор User10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1238
Последний ответ 07 Ноя 2018, 14:41
от alexandr_ll
Получить в СКД Строку "ВсегоПродаж"

Автор DeepushkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 391
Последний ответ 21 Янв 2019, 16:57
от Deepushka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
MuI_I_Ika MuI_I_Ika
35 Сообщений
BuhRust
35 Сообщений
Бактыжан Килибаев Бактыжан Килибаев
32 Сообщений
LexaK
30 Сообщений
Chgdz
25 Сообщений
alexandr_ll
25 Сообщений
wise wise
22 Сообщений
Пересвет Пересвет
19 Сообщений
zaq1234
10 Сообщений

* Кто онлайн

  • Точка Гостей: 777
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal