Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 04:44

Re: Нужна помощь ученику

Автор vladialim, 04 ноя 2019, 15:22

0 Пользователей и 1 гость просматривают эту тему.

vladialim

Всем привет, 8.3 учебная выполняю лабораторные задание и столкнулся с проблемой

Процедура МатриалыТоварПриИзменении(Элемент)
СТЧ = ЭлементыФормы.Материалы.ТекущиеДанные;
Товар = СокрЛП(СТЧ.Товар);
СпрН = Элементы.Справочники.Единицы;
Объект = СпрН.ВыбратьИерархически();
Пока Объект.Следующий() Цикл
   Номенкл = СокрЛП(Объект.Наименование);
   Код = Объект.Код;
   ЭлСпр = СпрН.НайтиПоКоду(Код);
   СТЧ.ЕдИзм = ЭлСпр.ЕдИзм;
   Если Номенкл = Товар Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
ЕдИзмВ = СокрЛП(СТЧ.ЕдИзм);
Выб = Элементы.Справочники.Единицы.ВыбратьИерархически();
Пока Выб.Следующий() Цикл
   ЕдИзмС = СокрЛП(Выб.Ссылка);
   СТЧ.Коэф = Выб.Коэфф;
   Если ЕдИзмВ = ЕдИзмС Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
КонецПроцедуры

Почему-то не видит Справочник

Геннадий ОбьГЭС

Дубль http://forum-1c.ru/index.php?topic=31778.0;msg=212690

И подсказка там же - в тексте выдаваемой ошибки

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск