Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2019, 11:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Re: Нужна помощь ученику  (Прочитано 309 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vladialim

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет, 8.3 учебная выполняю лабораторные задание и столкнулся с проблемой

Процедура МатриалыТоварПриИзменении(Элемент)
СТЧ = ЭлементыФормы.Материалы.ТекущиеДанные;
Товар = СокрЛП(СТЧ.Товар);
СпрН = Элементы.Справочники.Единицы;
Объект = СпрН.ВыбратьИерархически();
Пока Объект.Следующий() Цикл
   Номенкл = СокрЛП(Объект.Наименование);
   Код = Объект.Код;
   ЭлСпр = СпрН.НайтиПоКоду(Код);
   СТЧ.ЕдИзм = ЭлСпр.ЕдИзм;
   Если Номенкл = Товар Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
ЕдИзмВ = СокрЛП(СТЧ.ЕдИзм);
Выб = Элементы.Справочники.Единицы.ВыбратьИерархически();
Пока Выб.Следующий() Цикл
   ЕдИзмС = СокрЛП(Выб.Ссылка);
   СТЧ.Коэф = Выб.Коэфф;
   Если ЕдИзмВ = ЕдИзмС Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
КонецПроцедуры

Почему-то не видит Справочник


Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3313
  • РЕПУТАЦИЯ: 140
  • КПД: 4%
  • Проблемы решу удаленно в 1С
  • Регистрация: 2015-03-12
  • Сайт: nsk1c.wordpress.com
  • Профессия: Программист 1С
Дубль http://forum-1c.ru/index.php?topic=31778.0;msg=212690

И подсказка там же - в тексте выдаваемой ошибки
Геннадий
Консультант-программист 1С
 Оплата после результата

Последний раз редактировалось: Геннадий ОбьГЭС; 05 Ноя 2019, 05:16


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
BuhRust
35 Сообщений
MuI_I_Ika MuI_I_Ika
35 Сообщений
Бактыжан Килибаев Бактыжан Килибаев
32 Сообщений
LexaK
30 Сообщений
Chgdz
25 Сообщений
alexandr_ll
25 Сообщений
wise wise
22 Сообщений
Пересвет Пересвет
19 Сообщений
aleon1
10 Сообщений

* Кто онлайн

  • Точка Гостей: 787
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal