Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 17:58

Не отображается список выбора на форме

Автор Yamuna, 25 окт 2019, 09:16

0 Пользователей и 1 гость просматривают эту тему.

Yamuna

добрый день, подскажите почему не отображается список выбора на форме обработки, создаю обработку МетаданныеДокумента и на форме создаю реквизит Список тип СписокЗначений,в свойствах Список выставляю галочку РежимВыбораИзСписка и ПриСозданииНаСервере заполняю его данными
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Для каждого Документ Из Метаданные.Документы Цикл
Элементы.Список.СписокВыбора.Добавить(Документ.Имя,Документ.Синоним);
КонецЦикла;
КонецПроцедуры

что то код криво отображается поэтому продублирую:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   Для каждого Документ Из Метаданные.Документы Цикл
      Элементы.Список.СписокВыбора.Добавить(Документ.Имя,Документ.Синоним);
   КонецЦикла;
КонецПроцедуры

все это было сделано в управляемом приложении Режим совместимости Версия 8.2.13, проверяю в пользовательском режиме все работает хорошо из выпадающего списка значение нормально выбирается и отображается на форме, потом решил попробовать постепенно режим совместимости менять и когда выбрал режим Версия 8.3.3 то после этого в пользовательском режиме выпадающий список работает список формируется но выбранное значение на форме не отображается поле остается пустым, что можно сделать,что бы значение отображалось?
и когда я решил опять поставить режим Версия 8.2.13 то при обновлении получил ошибку
В процессе обновления информационной базы произошла критическая ошибка
по причине:
Ошибка SDBL:
В схеме базы данных нет таблицы с именем AccRgOpt
кто то может подсказать как это исправить?

alexandr_ll

Цитата: Yamuna от 25 окт 2019, 09:16
все это было сделано в управляемом приложении Режим совместимости Версия 8.2.13, проверяю в пользовательском режиме все работает хорошо из выпадающего списка значение нормально выбирается и отображается на форме, потом решил попробовать постепенно режим совместимости менять и когда выбрал режим Версия 8.3.3 то после этого в пользовательском режиме выпадающий список работает список формируется но выбранное значение на форме не отображается поле остается пустым, что можно сделать,что бы значение отображалось?
и когда я решил опять поставить режим Версия 8.2.13 то при обновлении получил ошибку
В процессе обновления информационной базы произошла критическая ошибка
по причине:
Ошибка SDBL:
В схеме базы данных нет таблицы с именем AccRgOpt
кто то может подсказать как это исправить?
В чем смысл ваших действий по изменению совместимости?
Перед любыми изменениями конфигурации следует делать резервные копии.

Yamuna

Цитата: alexandr_ll от 25 окт 2019, 11:55
В чем смысл ваших действий по изменению совместимости?
Перед любыми изменениями конфигурации следует делать резервные копии.
ну я заметил что если этот самый код, я имею ввиду с отображением списка выбора попробовать на 8.3 то он не работает, и решил понять когда это происходит, и когда режим совместимости переключаю на Версия 8.3.3, то все ломается и на более старших тоже, поэтому и спрашиваю может кто то подскажет почему не выбирается значение списка выбора на форме и почему ошибка вышла, может кто нибудь сталкивался.... вы не знаете?

LexaK

уберите все совместимости и попробуйте этот пример см. вложение
ответ Понравился? (в смысле пригодился?)

Yamuna

Цитата: LexaK от 25 окт 2019, 16:07
уберите все совместимости и попробуйте этот пример см. вложение
ЛехаК Спасибо большое

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск