Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 01:09

Ошибка при открытие отчета на клиенте

Автор Артем!, 24 окт 2019, 11:36

0 Пользователей и 1 гость просматривают эту тему.

Артем!

Ошибка при открытие отчета на клиенте
{Отчет.ЗакупкиПоДокументам.Форма.ФормаОтчета.Форма(49)}: Ошибка при вызове метода контекста (Вывести)
   ТабДок.Вывести(ОбластьЗаголовок);
по причине:
Несоответствие типов (параметр номер '1')

&НаКлиенте
Процедура Сформировать(Команда)
СформироватьОтчет(ТабДок);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура СформироватьОтчет(ТабДок)

//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
Макет = Отчеты.ЗакупкиПоДокументам.ПолучитьМакет("Макет");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриходнаяТовары.Ссылка.Контрагент КАК Контрагент,
| ПРЕДСТАВЛЕНИЕ(ПриходнаяТовары.Ссылка.Контрагент),
| ПриходнаяТовары.Номенклатура,
| ПРЕДСТАВЛЕНИЕ(ПриходнаяТовары.Номенклатура),
| СУММА(ПриходнаяТовары.Количество) КАК Количество,
| СУММА(ПриходнаяТовары.Сумма) КАК Сумма
|ИЗ
| Документ.Приходная.Товары КАК ПриходнаяТовары
|ГДЕ
| ПриходнаяТовары.Ссылка.Проведен
|
|СГРУППИРОВАТЬ ПО
| ПриходнаяТовары.Ссылка.Контрагент,
| ПриходнаяТовары.Номенклатура
|ИТОГИ
| СУММА(Сумма)
|ПО
| ОБЩИЕ,
| Контрагент";

РезультатЗапроса = Запрос.Выполнить();
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьКонтрагент = Макет.ПолучитьОбласть("Контрагент");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");


ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаКонтрагент = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаКонтрагент.Следующий() Цикл
ОбластьКонтрагент.Параметры.Заполнить(ВыборкаКонтрагент);
ТабДок.Вывести(ОбластьКонтрагент, ВыборкаКонтрагент.Уровень());

ВыборкаДетальныеЗаписи = ВыборкаКонтрагент.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА



КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск