Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Ноя 2018, 03:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите с отчетом  (Прочитано 1852 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн лось911

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток!
Помогите пожалуйста начинающему)
Дали отчет,который выводит план выпуска товара на месяц.
Попросили дописать выпуск товара
подскажи кто чем может)
1с 7.7. самописная

план по регистру План
выпуск по регистру ВыпускПродукции


//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
     рег=СоздатьОбъект("Регистр.План");
     рег1=СоздатьОбъект("Регистр.ВыпускПродукции");
    ВыбНачПериода=ДобавитьМесяц(ВыбКонПериода,-2);
    ВыбКонПериода2=КонМесяца(ВыбКонПериода);
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода2;
    |Номенклатура = Регистр.План.Номенклатура;
    |План = Регистр.План.План;
    |Заказ = Регистр.ВыпускПродукции.Заказ;
    |Количество = Регистр.План.Количество;
    |Сумма = Регистр.План.Сумма;
    |ТекущийДокумент = Регистр.План.ТекущийДокумент;
    |Подразделение = Регистр.План.Подразделение;
    |Срок = Регистр.План.ДатаИсполнения;
    |Функция КоличествоПриход = Приход(Количество);
    |Функция КоличествоРасход = Расход(Количество);
    |Функция СуммаПриход = Приход(Сумма);
    |Функция СуммаРасход = Расход(Сумма);
    |Группировка Подразделение;
    |Группировка Номенклатура;
    |Условие(Срок <= КонМесяца(ВыбКонПериода));
    |Условие(Срок >= НачМесяца(ВыбКонПериода));
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
   
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей Подразделение
        Таб.ВывестиСекцию("Подразделение");
        Пока Запрос.Группировка(2) = 1 Цикл
            // Заполнение полей Номенклатура
                ЗаДеньПоУч=0;
                Если Запрос.Номенклатура.ЭтоГруппа()=0 Тогда
                    ЗаДень=0;
                    Рег.УстановитьФильтр(Запрос.Номенклатура);
                    рег.ВыбратьДвижения(ВыбКонПериода);       
                    Пока Рег.ПолучитьДвижение()>0 Цикл
                    Если Рег.Расход=1 Тогда
                        ЗаДень=Рег.Количество;
                        ЗаДеньПоУч=ЗаДеньПоУч+ЗаДень;
                    КонецЕсли;
                    //Запрос.КоличествоПриход
                    КонецЦикла;
                   
                    Таб.ВывестиСекцию("Номенклатура");           
                КонецЕсли

            КонецЦикла;
           
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 785
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
а попробуй так же конструктором  :D   понемногу дойдешь


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
47 Сообщений
alex0402
44 Сообщений
alexandr_ll
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 171
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal