Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 20:58

Не подставляется основная организация УНФ 1.6.18.168

Автор Михаил Е, 04 окт 2019, 19:50

0 Пользователей и 1 гость просматривают эту тему.

Михаил Е


Доброго времени суток, подскажите где косяк?

&НаКлиенте
Процедура ПриОткрытии(Отказ)   
   ВывестиОсновнуюОрганизациюНаСервере();
   Объект.Организация = Орг;
   КонецПроцедуры

&НаСервере
Процедура ВывестиОсновнуюОрганизациюНаСервере()
   Орг = Справочники.Организации.ОрганизацияПоУмолчанию();
КонецПроцедуры

Ошибка: Переменная не определена (Орг)
   Объект.Организация = <<?>>Орг; (Проверка: Тонкий клиент)

DmitriyF

Цитата: Михаил Е от 04 окт 2019, 19:50

Доброго времени суток, подскажите где косяк?

&НаКлиенте
Процедура ПриОткрытии(Отказ)   
   ВывестиОсновнуюОрганизациюНаСервере();
   Объект.Организация = Орг;
   КонецПроцедуры

&НаСервере
Процедура ВывестиОсновнуюОрганизациюНаСервере()
   Орг = Справочники.Организации.ОрганизацияПоУмолчанию();
КонецПроцедуры

Ошибка: Переменная не определена (Орг)
   Объект.Организация = <<?>>Орг; (Проверка: Тонкий клиент)
Так установи ее на сервере, организацию. Тогда уж это надо делать при создании на сервере, а не открытии.

АлександрВладимирович

Переменная Орг в процедуре ПриОткрытии(Отказ) понятия не имеет о том, что переменной Орг в процедуре ВывестиОсновнуюОрганизациюНаСервере() присвоили какое-то значение. Это две разные переменные.

Надо так:

&НаКлиенте
Процедура ПриОткрытии(Отказ)   
   Объект.Организация = ВывестиОсновнуюОрганизациюНаСервере();
КонецПроцедуры

&НаСервере
Функция ВывестиОсновнуюОрганизациюНаСервере()
   Возврат Справочники.Организации.ОрганизацияПоУмолчанию();
КонецФункции

Михаил Е


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск