Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 10:29

Нужна помощь, не могу разобраться

Автор Sheriff, 02 окт 2019, 09:07

0 Пользователей и 1 гость просматривают эту тему.

Sheriff

Всем привет! Использую 1С:Предприятие 8.3 (8.3.13.1690)
конфа - Бухгалтерия для Казахстана, редакция 3.0, разработка для Казахстана: «1С-Рейтинг» (3.0.31.2)
Сделал в расширении изменение на документ Требование-накладная.
Теперь в печатную форму пытаюсь вывести вес вагонов через запятую, но вот если в табличной части документа Отгрузка вагонов повторяется вес, то в печатной форме он почему -то выходит только как будто там всего одна позиция, хотя там их 3 вагона, но с одинаковым весом.
С другими документами где вес у вагонов разный, всё нормально при печати.
Функция ПолучитьВесВагонов(ДокСсылка)

МассивНомеров="";

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | ОтгрузкаВагоновВагоны.Тоннаж КАК Тоннаж
               |ИЗ
               | Документ.ЦЗС_ОтгрузкаВагонов.Вагоны КАК ОтгрузкаВагоновВагоны
               | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЦЗС_ОтгрузкаВагонов КАК ОтгрузкаВагонов
               | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ТребованиеНакладная.ЦЗС_ДокументыОтгрузкиВагонами КАК ТребованиеНакладнаяЦЗС_ДокументыОтгрузкиВагонами
               | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ТребованиеНакладная КАК ТребованиеНакладная
               | ПО ТребованиеНакладнаяЦЗС_ДокументыОтгрузкиВагонами.Ссылка = ТребованиеНакладная.Ссылка
               | ПО (ТребованиеНакладнаяЦЗС_ДокументыОтгрузкиВагонами.СсылкаНаДокумент = ОтгрузкаВагонов.Ссылка)
               | ПО ОтгрузкаВагоновВагоны.Ссылка = ОтгрузкаВагонов.Ссылка
               |ГДЕ
               | ТребованиеНакладная.Ссылка = &Ссылка
               |
               |СГРУППИРОВАТЬ ПО
               | ОтгрузкаВагоновВагоны.Тоннаж";

Запрос.УстановитьПараметр("Ссылка", ДокСсылка);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Сч=0;
Всего=0;
Если Выборка.Количество()>0 Тогда
Всего=Выборка.Количество();

Сч =1;
Пока Выборка.Следующий() Цикл

   Если Всего<>Сч Тогда
     Сч=Сч+1;
  МассивНомеров=МассивНомеров+" "+Выборка.Тоннаж+",";
   Иначе
МассивНомеров=МассивНомеров+" "+Выборка.Тоннаж;
   КонецЕсли;

КонецЦикла;

КонецЕсли;

Возврат МассивНомеров;

КонецФункции // ПолучитьВесВагонов()
 
[/u]

Sheriff

СГРУППИРОВАТЬ ПО
НомерСтроки
так получилось вывести, НО, теперь нужно их в столбец и посчитать итого.
Как это сделать?
Добавлено: 03 окт 2019, 05:25


Вот так данные выводятся сейчас
№ вагонов   :  24381170, 24551459, 52034261                   
Вес вагонов :  66, 66, 66                   

Эти данные в печатной форме выводятся, НО, они в строчку все
Как их каждую строку сделать в столбец, чтоб номер вагона, соответствовал весу вагона
Ну и по итогу, общий все в конце

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск