Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
04 Июл 2020, 18:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Хочу из документов ЗаказПоставщика Табличной части товары перенести Номенклатуру и цену в документ Установка цен номенклатуры  (Прочитано 416 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ruslan09609

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-07-24
  • Сайт: 
  • Профессия: Программист 1С
Из документа ЗаказПоставщика ТЧ Товары перенести в Документ УстановкаЦенНоменклатуры ТЧ Товары.
Вот мой код,но он не работает подскажите пожалуйста что я не так сделал.
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПоставщикуТовары.Номенклатура,
| ЗаказПоставщикуТовары.Цена
|ИЗ
| Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
|ГДЕ
| ЗаказПоставщикуТовары.Ссылка.Проведен
|
|СГРУППИРОВАТЬ ПО
| ЗаказПоставщикуТовары.Номенклатура,
| ЗаказПоставщикуТовары.Цена";

РезультатЗапроса = Запрос.Выполнить().Выгрузить();

УстановкаЦенНоменклатурыОбъект = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
УстановкаЦенНоменклатурыОбъект.Дата = ТекущаяДата();

Для каждого ТекСтр из  УстановкаЦенНоменклатурыОбъект.Товары Цикл
ЗаполнитьЗначенияСвойств(УстановкаЦенНоменклатурыОбъект,РезультатЗапроса);
КонецЦикла;

УстановкаЦенНоменклатурыОбъект.Записать(РежимЗаписиДокумента.Запись);


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1371
  • РЕПУТАЦИЯ: 208
  • КПД: 15%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Из документа ЗаказПоставщика ТЧ Товары перенести в Документ УстановкаЦенНоменклатуры ТЧ Товары.
Вот мой код,но он не работает подскажите пожалуйста что я не так сделал.
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПоставщикуТовары.Номенклатура,
| ЗаказПоставщикуТовары.Цена
|ИЗ
| Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
|ГДЕ
| ЗаказПоставщикуТовары.Ссылка.Проведен
|
|СГРУППИРОВАТЬ ПО
| ЗаказПоставщикуТовары.Номенклатура,
| ЗаказПоставщикуТовары.Цена";

РезультатЗапроса = Запрос.Выполнить().Выгрузить();

УстановкаЦенНоменклатурыОбъект = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
УстановкаЦенНоменклатурыОбъект.Дата = ТекущаяДата();

Для каждого ТекСтр из  УстановкаЦенНоменклатурыОбъект.Товары Цикл
ЗаполнитьЗначенияСвойств(УстановкаЦенНоменклатурыОбъект,РезультатЗапроса);
КонецЦикла;

УстановкаЦенНоменклатурыОбъект.Записать(РежимЗаписиДокумента.Запись);
Такой запрос не будет работать в 1С Предприятие 7.7

Оффлайн prog1c7.7

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Если 8 то Вместо:
 
Для каждого ТекСтр из  УстановкаЦенНоменклатурыОбъект.Товары Цикл
        ЗаполнитьЗначенияСвойств(УстановкаЦенНоменклатурыОбъект,РезультатЗапроса);
    КонецЦикла;
Надо:
     
Для каждого л1  из РезультатЗапроса   Цикл            
        НовСтрдокумента = УстановкаЦенНоменклатурыОбъект.Товары.Добавить();             
        ЗаполнитьЗначенияСвойств(НовСтрдокумента,л1);
     КонецЦикла;

..кактотак


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
LexaK
40 Сообщений
DmitriyF DmitriyF
28 Сообщений
alexandr_ll
14 Сообщений
PLTBWH
13 Сообщений
antoneus antoneus
10 Сообщений
ToryFree ToryFree
9 Сообщений
bossko 844 bossko 844
8 Сообщений
МЮлия
8 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal