Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2019, 10:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части. Обработка  (Прочитано 98 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jyurik

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
Обработкой заполнения таб. час я заполняю таб. Часть док. Реализации услуг по переработки. Запросом обращаюсь к конкретному док Отчет производства за смену и гружу его тч в тч реализации. Столкнулся с такой ситуацией, в тч реализации, есть колонка «Всего» она не как не описана – это не реквизит таб. части и нет никого типа, просто колонка с названием Всего. На форме она заполняется так:
«    Если ЭлементыФормы.Продукция.Колонки.Всего.Видимость    Тогда
        ОформлениеСтроки.Ячейки.Всего.ОтображатьТекст = Истина;
        ОформлениеСтроки.Ячейки.Всего.Текст = ОбщегоНазначения.ФорматСумм(ДанныеСтроки.Сумма
                                            + ?(СуммаВключаетНДС, 0, ДанныеСтроки.СуммаНДС));
    КонецЕсли;
».
Вопрос: Может, кто сталкивался с этим? Как мне передать данные в эту колонку? Как ее определить внешней обработкой?
Мой результат загрузки данных в таб. Часть:
"    Результат = Запрос.Выполнить().Выгрузить();
   
    ТабличнаяЧасть.Очистить();
       
    Для Каждого ЭлементРезультата из Результат Цикл
        НоваяСтрокаТЧ = ТабличнаяЧасть.Добавить();       
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);
        НоваяСтрокаТЧ.Сумма = ЭлементРезультата.Цена * ЭлементРезультата.Количество;
        НоваяСтрокаТЧ.СуммаНДС = НоваяСтрокаТЧ.Сумма*"0,2";
    КонецЦикла;
   
    СчетаУчетаВДокументах.ЗаполнитьСчетаУчетаТабличнойЧасти("Продукция", ТабличнаяЧасть, Объект, Истина, Истина, Истина, Истина, Истина);
"


Онлайн LexaK

  • *****
  • Сообщений: 1816
  • РЕПУТАЦИЯ: 532
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Колонка: Всего, это вычисляемое поле, ни чего туда передавать не надо, при открытии формы все заполнится само. Главное остальные поля ТЧ правильно заполните.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн jyurik

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
Колонка: Всего, это вычисляемое поле, ни чего туда передавать не надо, при открытии формы все заполнится само. Главное остальные поля ТЧ правильно заполните.
Я немного переделал запросе, и он сейчас тупо заполняет табличную часть данными и все ровно не работает правильно отображение данных в таблице
Должно быть Всего = Сумма + Сумма НДС, а меня почему-то Всего = Сумме
Добавлено: 11 Сен 2019, 10:18

Колонка: Всего, это вычисляемое поле, ни чего туда передавать не надо, при открытии формы все заполнится само. Главное остальные поля ТЧ правильно заполните.
Я немного переделал запросе, и он сейчас тупо заполняет табличную часть данными и все ровно не работает правильно отображение данных в таблице
Должно быть Всего = Сумма + Сумма НДС, а меня почему-то Всего = Сумме

Вот сейчас результат запроса:
Результат = Запрос.Выполнить().Выгрузить();
   
    ТабличнаяЧасть.Очистить();
       
    Для Каждого ЭлементРезультата из Результат Цикл
        НоваяСтрокаТЧ = ТабличнаяЧасть.Добавить();       
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);
    КонецЦикла;
   
    СчетаУчетаВДокументах.ЗаполнитьСчетаУчетаТабличнойЧасти("Продукция", ТабличнаяЧасть, Объект, Истина, Истина, Истина, Истина, Истина);

Онлайн LexaK

  • *****
  • Сообщений: 1816
  • РЕПУТАЦИЯ: 532
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Должно быть Всего = Сумма + СуммаНДС, а меня почему-то Всего = Сумме
прямо как в начальной школе, уравнение с одной переменной,
попробуйте заполнить СуммаНДС
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн jyurik

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Должно быть Всего = Сумма + СуммаНДС, а меня почему-то Всего = Сумме
прямо как в начальной школе, уравнение с одной переменной,
попробуйте заполнить СуммаНДС
Извините, не понял, Сумма НДС у меня идет из запроса, и она заполняется в табличной части


Теги:
 

Три печатные формы - одна обработка. Внешние печатные формы в КА 2.4

Автор jetdiggerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 528
Последний ответ 10 Дек 2018, 01:05
от jetdigger
Ошибка "Поле объекта не обнаружено" при записи табл.части документа "ОперацияБух"

Автор Q37Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 972
Последний ответ 18 Авг 2018, 20:18
от Q37
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 10246
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4357
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Обработка "ПодборНоменклатуры"

Автор BigAnnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3741
Последний ответ 18 Апр 2012, 20:38
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
92 Сообщений
LexaK
53 Сообщений
alexandr_ll
41 Сообщений
Yamuna
35 Сообщений
KOI8-R
27 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
BuhRust
21 Сообщений
DmitriyF DmitriyF
19 Сообщений
Рашитовна Рашитовна
18 Сообщений

* Кто онлайн

  • Точка Гостей: 645
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal