Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
07 Авг 2020, 18:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: PUSH уведомления андроид  (Прочитано 2857 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн temrmal

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2011-11-10
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день! У кого настроены и РАБОТАЮТ в настоящее время PUSH уведомления на мобильной платформе?
Делаю все как указано на разных форумах, ответ приходит что GCM has been deactivated. Перешел на Firebird service - туда вообще не может подключиться как напрямую, так и через сервис 1С для push сообщений


Оффлайн temrmal

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2011-11-10
  • Сайт: 
  • Профессия: Программист 8.1
Поделюсь решением: (огромная благодарность техподдержке с сервиса 1c.notifications) GCM более не работает, переходим на FCM. Идентификатор запрашиваем без параметров, тогда получаем идентификатор именно FCM.

Самое главное - с FCM работает платформа только с версии 8.3.13.1865.

Осталась проблема одна - уведомления приходят с вибрацией, звука нет почему то. Но это уже может телефон настройку копать

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 7103
  • РЕПУТАЦИЯ: 844
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Было бы вообще круто если бы еще и код привели.

Оффлайн Dimensh

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-11-15
  • Сайт: 
  • Профессия: Программист 1С
про пуш множество статей, а вот разобраться все не было времени, теперь знаю куда копать:zebzdr:

Оффлайн temrmal

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2011-11-10
  • Сайт: 
  • Профессия: Программист 8.1
Было бы вообще круто если бы еще и код привели.
Да пожалуйста)))

Про мобильное приложение кратко (в инете много инфы, код один)
1. при запуске мобильного приложения в коде получаем PUSHID и передаем его на сервер, чтобы там запомнить

#Если МобильноеПриложениеКлиент Тогда 
Идентификатор = ДоставляемыеУведомления.ПолучитьИдентификаторПодписчикаУведомлений();// вот тут параметры уже не нужны
Результат = ОбменWS.ЗаписатьPushID(Идентификатор);  //вот это процедура общего модуля, где через веб сервис передается идентификатор с ID устройством. (Потом к нему получателей PUSH уведомлений достаем)
Если НЕ Результат.Успешно Тогда
Сообщить(Результат.Сообщения[0]);
КонецЕсли;

Оповещение = Новый ОписаниеОповещения("ОбработатьPushСообщение",УведомленияКлиент);
ДоставляемыеУведомления.ПодключитьОбработчикУведомлений(Оповещение);
#КонецЕсли


Далее при событии определяем получателей, вернее их PUSH ID и отправляем

Процедура ОтправитьPUSHУведомление(Получатели,Заголовок = "",Данные,Текст = "") Экспорт

Уведомление = Новый ДоставляемоеУведомление;
Уведомление.Заголовок = Заголовок;
Уведомление.Данные = Данные;
Уведомление.Текст = Текст;
Для Каждого Получатель ИЗ Получатели Цикл
Уведомление.Получатели.Добавить(Получатель.Получить());
КонецЦикла;

ОтправкаДоставляемыхУведомлений.Отправить(Уведомление,"PUSH_SRV_API_KEY_8F5ХХХХХ_DХХХ_ХХХХ_ХХХХ_ACF6ХХХХХХХХ",,Истина);

КонецПроцедуры

Кстати, звук в итоге получилось включить. По умолчанию 1С на андроиде уведомления беззвучно получает. Через стандартные настройки Андроид (на xiaomi удерживая иконку появится меню и там пункт уведомление) можно выбрать звук

Передать звук с 1с, в параметрах, как в справке написано не получилось, но это уже извращение.
Всем успехов!!!


Последний раз редактировалось: MuI_I_Ika; 09 Янв 2020, 22:09


Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
LexaK
33 Сообщений
ToryFree ToryFree
28 Сообщений
alexandr_ll
26 Сообщений
antoneus antoneus
23 Сообщений
Алексей_1985_06
22 Сообщений
DmitriyF DmitriyF
20 Сообщений
Алексей Рожков Алексей Рожков
12 Сообщений
BuhRust
10 Сообщений
judnikov
10 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal