Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
31 Мар 2020, 22:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Всем добрый день,подскажите как реализовать в документе реализации товаров и услуг добавить расчет от всего то есть при вводе всего рассчитывается ндс и цена  (Прочитано 357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн skynet7017

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-10
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите алгоритм действий,добавляю в модуль УслугиВсегоПриИзменение
СтрокаТаблицы = Элементы[ИмяТаблицы].ТекущиеДанные;
СтрокаТаблицы.СуммаНДС =   РассчитатьСуммуНДС(СтрокаТаблицы.Всего,  ИСТИНА,   СтрокаТаблицы.СтавкаНДС);
       
СтрокаТаблицы.Сумма = СтрокаТаблицы.Всего - ?(Объект.СуммаВключаетНДС, 0, СтрокаТаблицы.СуммаНДС);


Функция РассчитатьСуммуНДС(Сумма, СуммаВключаетНДС, СтавкаНДС) Экспорт

    Если СуммаВключаетНДС Тогда
        СуммаБезНДС = 100 * Сумма / (100 + СтавкаНДС);
        СуммаНДС = Сумма - СуммаБезНДС;
    Иначе
        СуммаБезНДС = Сумма;
    КонецЕсли;

    Если НЕ СуммаВключаетНДС Тогда
        СуммаНДС = СуммаБезНДС * СтавкаНДС / 100;
    КонецЕсли;
   
    Возврат СуммаНДС;

КонецФункции // РассчитатьСуммуНДС()


Теги: БП3.0 
 

В 1с предприятие 8.3 управление торговлей 11.1 как изменить цену на несколько товаров с одним и тем же артиклем на последнюю введенную цену с помощью загрузки обработки или как это сделать в 1с с помощью программирования? прилагаю полный текст обработки

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 696
Последний ответ 11 Фев 2019, 15:15
от сергей123
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 6676
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Отчет "Динамика закупок" ("Анализ себестоимости товаров") в Управлении Торговлей 11

Автор GunnerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3657
Последний ответ 19 Фев 2016, 10:24
от Надеждда
Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1350
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1151
Последний ответ 03 Мар 2018, 16:14
от useronforum

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
LexaK
60 Сообщений
antoneus antoneus
32 Сообщений
alexandr_ll
32 Сообщений
Алексей Рожков Алексей Рожков
31 Сообщений
ef0din
25 Сообщений
wise wise
20 Сообщений
Varg . Varg .
19 Сообщений
Алексей_1985_06
19 Сообщений
Alexbis
15 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal