Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 00:38

ActiveDocument Внешняя печатная форма

Автор Денис Степанищев, 28 авг 2019, 14:55

0 Пользователей и 1 гость просматривают эту тему.

Денис Степанищев

Добрый день. Сделал внешнюю печатную форму с макетом типа ActiveDocument. Добавил ее в типовую УТ 11. Отрабатывает правильно. Однако, выдает системная ошибка.

{ОбщийМодуль.УправлениеПечатью.Модуль(1658)}: В обработчике печати не был сформирован табличный документ для ПЕЧАТЬТест

Листинг куска процедуры:
// Проверим, все ли макеты были сформированы.
    Для Каждого ПечатнаяФорма Из КоллекцияПечатныхФорм Цикл
        Если ПечатнаяФорма.ТабличныйДокумент = Неопределено Тогда
            ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
                ПечатнаяФорма.ИмяМакета);
            ВызватьИсключение(ТекстСообщенияОбОшибке);
        КонецЕсли;
         
        ПечатнаяФорма.ТабличныйДокумент.КоличествоЭкземпляров = ПечатнаяФорма.Экземпляров;
    КонецЦикла;


Вопрос. Как при формировании ВПР с типом макета activedocument заполнить "ПечатнаяФорма.ТабличныйДокумент"?


Листинг процедуры формирования макета:

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
   Договор = ПолучитьМакет("Макет"); // получим макет-ActiveDocument
   MSWord = Договор.Получить();   
   Попытка
       w = MSWord.Application.Documents(1);
       w.Activate();         
           
       Замена = w.Content.Find;Замена.Execute("[ИННКПП]",Ложь, Истина, Ложь, , , Истина, , Ложь, МассивОбъектов[0].Контрагент.ИНН + "/" + МассивОбъектов[0].Организация.КПП);
       MSWord.visible=true;   
    MSWord.Activate();
Исключение
    Сообщить(ОписаниеОшибки());
    MSWord.Application.Quit();
КонецПопытки;
     

КонецПроцедуры // Печать()

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск