Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 06:55

Создание условий

Автор Ивашка, 27 авг 2019, 17:52

0 Пользователей и 1 гость просматривают эту тему.

Ивашка

Надо создать условие при котором если указывается организация ИП, то в макете в области заголовке указывается один текст, если указывается организация ООО, а другой в этом же макете указывается уже другой текст. Как написать условия?
&НаСервере
Функция СформироватьДоговорПрицеп()
ТабличныйДокумент = Новый ТабличныйДокумент;
ОтчетОбъект = РеквизитФормыВЗначение("Объект");
МакетОбработки = ОтчетОбъект.ПолучитьМакет("Прицеп");
//МакетОбработки = ПолучитьМакетНаСервере();
////заполняем шапку
ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.ТекДата = Формат(ЭтотОбъект.ТекДата, "ДЛФ=ДД");
Если ЗначениеЗаполнено(объект.Договор) Тогда
ОбластьШапка.Параметры.Ном = Число(Прав(Объект.Договор.Код,3));
КонецЕсли;
ТабличныйДокумент.Вывести(ОбластьШапка);

Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
ОбластьТело = МакетОбработки.ПолучитьОбласть("Тело");
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец;
//ОбластьТело.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,);
ОбластьТело.Параметры.ОГРН = Объект.Продавец.ОГРН;
ОбластьТело.Параметры.ПокупательФИО = Объект.Покупатель;
ОбластьТело.Параметры.ПокупательАдрес = Объект.Покупатель.А_Адрес; 
ТабличныйДокумент.Вывести(ОбластьТело);
Иначе
ОбластьТело = МакетОбработки.ПолучитьОбласть("ТелоЮр");
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец;
ОбластьТело.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,);
ТабличныйДокумент.Вывести(ОбластьТело);
КонецЕсли;

ОбластьТело1 = МакетОбработки.ПолучитьОбласть("Тело1");
ОбластьТело1.Параметры.Марка = Объект.Автомобиль.А_Марка;
ОбластьТело1.Параметры.Модель = Объект.Автомобиль.А_Модель;
ОбластьТело1.Параметры.ВИН = Объект.Автомобиль.А_VIN;
ОбластьТело1.Параметры.ГодВыпуска = Объект.Автомобиль.А_ГодВыпуска; 
ОбластьТело1.Параметры.Сумма = СуммаПродажи;
ТабличныйДокумент.Вывести(ОбластьТело1);

ОбластьПодписиПродавец = МакетОбработки.ПолучитьОбласть("ПодписиПродавец");
ОбластьПодписиПродавец.Параметры.ПродавецФИО = Объект.Продавец;
ОбластьПодписиПродавец.Параметры.ИННПродавца = "ИНН: "+Объект.Продавец.ИНН;
ОбластьПодписиПродавец.Параметры.КПППродавца = "КПП: "+Объект.Продавец.КПП;
ОбластьПодписиПродавец.Параметры.АдресПродавца = ДернутьАдрес(Объект.Продавец);
ОбластьПодписиПродавец.Параметры.ФиоДиректора = Объект.Продавец.Руководитель;
ТабличныйДокумент.Вывести(ОбластьПодписиПродавец);

Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
ОбластьПодписиФизПокупатель = МакетОбработки.ПолучитьОбласть("ПодписиФизПокупатель");
ОбластьПодписиФизПокупатель.Параметры.ПокупательФио = Объект.Покупатель;
ОбластьПодписиФизПокупатель.Параметры.ПаспортПокупатель = "серия: "+Объект.Покупатель.А_СерияПаспорта+" номер: "+Объект.Покупатель.А_НомерПаспорта; 
ТабличныйДокумент.Вывести(ОбластьПодписиФизПокупатель);
Иначе
ОбластьПодписиЮрПокупатель = МакетОбработки.ПолучитьОбласть("ПодписиЮрПокупатель");
ОбластьПодписиЮрПокупатель.Параметры.ПокупательФИО = Объект.Покупатель;
ОбластьПодписиЮрПокупатель.Параметры.ИННПокупателя = "ИНН: "+Объект.Покупатель.ИНН;
ОбластьПодписиЮрПокупатель.Параметры.КПППокупателя = "КПП: "+Объект.Покупатель.КПП;
ТабличныйДокумент.Вывести(ОбластьПодписиЮрПокупатель);
КонецЕсли;

ТабличныйДокумент.АвтоМасштаб = Истина;
Возврат ТабличныйДокумент;

AntS

Уточните что за конфигурация у вас. Но если БП, то проверять значение реквизита "ЮридическоеФизическоеЛицо" контрагента.
Проглядел - на скринах видно что Розница. В любом случае искать подобный реквизит контрагента и делать его проверку.

Ивашка

неправильно?
Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
Если Объект.Продавец = Перечисления.ЮрФизЛицо.ИндивидуальныйПредприниматель Тогда
ОбластьТело = МакетОбработки.ПолучитьОбласть("Тело"); 
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец;
    ОбластьТело.Параметры.ОГРН = Объект.Продавец.ОГРН;
ОбластьТело.Параметры.ПокупательФИО = Объект.Покупатель;
ОбластьТело.Параметры.ПокупательАдрес = Объект.Покупатель.А_Адрес;
ОбластьТело.Параметры.ПокупательСерия = Объект.Покупатель.А_СерияПаспорта;
ОбластьТело.Параметры.ПокупательНомер = Объект.Покупатель.А_НомерПаспорта;
ОбластьТело.Параметры.ПокупательВыданДата = Формат(Объект.Покупатель.А_ДатаВыдачи,"ДЛФ=Д");
ОбластьТело.Параметры.ПокупательВыданКем = Объект.Покупатель.А_КемВыдан;
ТабличныйДокумент.Вывести(ОбластьТело);
Иначе
ОбластьТело = МакетОбработки.ПолучитьОбласть("ТелоЮр");
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец;
ОбластьТело.Параметры.ОГРН = Объект.Продавец.ОГРН;
  ОбластьТело.Параметры.ПокупательФИО = Объект.Покупатель;
ОбластьТело.Параметры.ИННПокупателя = Объект.Покупатель.ИНН;
ОбластьТело.Параметры.КПППокупателя = Объект.Покупатель.КПП;
ОбластьТело.Параметры.ПокупательАдрес = ДернутьАдрес(Объект.Покупатель);
ТабличныйДокумент.Вывести(ОбластьТело);
КонецЕсли;
КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск