Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск в докуенте по всем реквизитам.  (Прочитано 1591 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста: пример поиска по всем реквизитам. Одна строчка, вводим текст и ищет во всем документе по заданным полям. Если находит то выводит в таблицу. Спасибо заранее.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Поиск по метаданным документа чтоли?

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
С большим удовольствием по читаю! :) Ещё бы ссылочку.

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
А что будем выводить? Ссылки?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
в обычной или управляемой форме? запрос или цикл?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Попробуй так:
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Документ");
Для каждого Документ Из Метаданные.Документы Цикл
   ПризнакНахождения = Ложь;
   Для каждого Реквизит Из Документ.Реквизиты Цикл
      Если ТипЗнч(Реквизит) = Тип("Строка") Тогда
         Если Реквизит = "Isandersam" Тогда         
            ПризнакНахождения = Истина;
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
   Если ПризнакНахождения = Истина Тогда
      ТаблицаЗначений.Добавить();
      ТаблицаЗначений.Документ = Документ.Ссылка;
   КонецЕсли;
КонецЦикла;


Теги:
 

Поиск в справочнике "Номенклатура" в УТ 11

Автор HolicРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1387
Последний ответ 08 Фев 2016, 20:53
от Holic
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 743
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika
Как установить "Поиск по точному совпадению" по умолчанию?

Автор BulatsergРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1669
Последний ответ 16 Сен 2016, 14:58
от Bulatserg
Поиск и замена способа отражения расходов в документе Передача материалов в эксплуатацию

Автор Елена ПлаксинаРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 2555
Последний ответ 08 Авг 2015, 00:37
от Дмитрий@
Поиск в основной форме обработки ссылок на формирование табличной части

Автор Nail2010Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3527
Последний ответ 21 Дек 2010, 10:02
от Nail2010

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal