Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 13:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск в докуенте по всем реквизитам.  (Прочитано 1709 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста: пример поиска по всем реквизитам. Одна строчка, вводим текст и ищет во всем документе по заданным полям. Если находит то выводит в таблицу. Спасибо заранее.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Поиск по метаданным документа чтоли?

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
С большим удовольствием по читаю! :) Ещё бы ссылочку.

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
А что будем выводить? Ссылки?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
в обычной или управляемой форме? запрос или цикл?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Попробуй так:
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Документ");
Для каждого Документ Из Метаданные.Документы Цикл
   ПризнакНахождения = Ложь;
   Для каждого Реквизит Из Документ.Реквизиты Цикл
      Если ТипЗнч(Реквизит) = Тип("Строка") Тогда
         Если Реквизит = "Isandersam" Тогда         
            ПризнакНахождения = Истина;
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
   Если ПризнакНахождения = Истина Тогда
      ТаблицаЗначений.Добавить();
      ТаблицаЗначений.Документ = Документ.Ссылка;
   КонецЕсли;
КонецЦикла;


Теги:
 

Поиск в справочнике "Номенклатура" в УТ 11

Автор HolicРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1718
Последний ответ 08 Фев 2016, 20:53
от Holic
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 880
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika
Как установить "Поиск по точному совпадению" по умолчанию?

Автор BulatsergРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2118
Последний ответ 16 Сен 2016, 14:58
от Bulatserg
Поиск по содержимому письма в 1с и вставить картинку в тело письма

Автор birusikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 263
Последний ответ 12 Янв 2018, 11:42
от birusik
Поиск и замена способа отражения расходов в документе Передача материалов в эксплуатацию

Автор Елена ПлаксинаРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 3041
Последний ответ 08 Авг 2015, 00:37
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
36 Сообщений
KOI8-R
35 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 795
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal