Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 01:17

Как удалить строку в табличной части документа

Автор Magn, 14 авг 2019, 14:22

0 Пользователей и 1 гость просматривают эту тему.

Magn

Здравствуйте. Такая задача: нужно ввести в поле число и после нажатия на кнопку удаляется строка под номером, число которое ввели. Написал код, но появляется ошибка.Подскажите в чем проблема. Неправильно указан путь? На форме добавлено поле и кнопка.

&НаКлиенте
Процедура УдалениеНоменклатуры(Команда)
   ТаблЧасть = Элементы.Продажа.ТекущиеДанные;
   Для Каждого Строка Из ТаблЧасть Цикл
      Если Строка.Количество = Объект.Условие Тогда
         Сообщить(Строка.Количество);
      //   ТаблЧасть.Удалить(Строка);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры

Ошибка: {Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(32)}: Итератор для значения не определен
   Для Каждого Строка Из ТаблЧасть Цикл

   

antoneus

Не понял - строка под номером, или строка, в которой Количество = Условие? В любом случае

Для каждого ТекСтрока из Объект.Продажи Цикл

Называть переменные в честь зарезервированных слов языка нежелательно. Удалять строки в цикле по этим же строкам тоже не есть гуд, тогда уж НайтиСтроки и в цикле по получившемуся массиву удалять строки.

Centzontotochtin

На самом деле все проще. Если реквизит, в котором содержится номер удаляемой строки называется, например, "Номер" тогда код будет такой:
&НаКлиенте
Процедура УдалениеНоменклатуры(Команда)
    Объект.Продажа.Удалить(Номер);
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск