Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2019, 10:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как удалить строку в табличной части документа  (Прочитано 215 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Magn

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-08-14
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Такая задача: нужно ввести в поле число и после нажатия на кнопку удаляется строка под номером, число которое ввели. Написал код, но появляется ошибка.Подскажите в чем проблема. Неправильно указан путь? На форме добавлено поле и кнопка.

&НаКлиенте
Процедура УдалениеНоменклатуры(Команда)
   ТаблЧасть = Элементы.Продажа.ТекущиеДанные;
   Для Каждого Строка Из ТаблЧасть Цикл
      Если Строка.Количество = Объект.Условие Тогда
         Сообщить(Строка.Количество);
      //   ТаблЧасть.Удалить(Строка);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры

Ошибка: {Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(32)}: Итератор для значения не определен
   Для Каждого Строка Из ТаблЧасть Цикл

   


Оффлайн antoneus

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 44
  • КПД: 27%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Не понял - строка под номером, или строка, в которой Количество = Условие? В любом случае

Для каждого ТекСтрока из Объект.Продажи Цикл

Называть переменные в честь зарезервированных слов языка нежелательно. Удалять строки в цикле по этим же строкам тоже не есть гуд, тогда уж НайтиСтроки и в цикле по получившемуся массиву удалять строки.

Последний раз редактировалось: antoneus; 14 Авг 2019, 15:23

Оффлайн Centzontotochtin

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-08-15
  • Сайт: 
  • Профессия: Разработчик 1С
На самом деле все проще. Если реквизит, в котором содержится номер удаляемой строки называется, например, "Номер" тогда код будет такой:
&НаКлиенте
Процедура УдалениеНоменклатуры(Команда)
    Объект.Продажа.Удалить(Номер);
КонецПроцедуры


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5483
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9107
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7153
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 12324
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8734
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
92 Сообщений
LexaK
53 Сообщений
alexandr_ll
41 Сообщений
Yamuna
35 Сообщений
KOI8-R
27 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
BuhRust
21 Сообщений
DmitriyF DmitriyF
19 Сообщений
Рашитовна Рашитовна
18 Сообщений

* Кто онлайн

  • Точка Гостей: 624
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal