Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 03:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С Бухгалтерия, Вывод итога сумм определенных строк таблицы  (Прочитано 7108 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн drwhite

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-20
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! Например есть "Приходный ордер". В нем таблица со столбцами "№, Отделение, Вид платежа, Сумма". Как вывести сумму по определенному виду платежа? (и как ее вывести прописью?)


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
в одном  ПКО есть один платеж.
ПКО - уникальный документ - по нему так сказать касса оприходуется,
он может быть создан по отчету либо еще какому основанию.
вопрос не совсем понятен. Если нужно прописью, то в конфигураторе -
документы-ПриходныйОрдер-форма-таблица- свойства ячейки покрутите где сумма стоит,но вообщето она и так прописью там.
можно поточнее вопрос?

Оффлайн drwhite

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-20
  • Сайт: 
  • Профессия: Программист 1С
Можно... Пример по строкам отчета:
№     Отделение     Вид платежа    Сумма
 1            А              Пенсия           500
 2            Б             Комуналка      1000
 3            В              Пенсия           800
 4            Г               УТСЗН           300
 5            Д            Комуналка        250

Итого                                          2850
          Та же сумма прописью

Итого: Пенсия 1300, Комуналка 1250, УТСЗН 300

Вот


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
"вид платежа" это у нормальных конф. "основание" чтоли?
заполняется вручную или выбирается из списка как то?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
ПКО=СоздатьОбъект("Документ.приходныйордер");
   ПКО.ВыбратьДокументы(Дата1,Дата2);
      ТБ = СоздатьОбъект("ТаблицаЗначений");
              ТБ.НоваяКолонка("Номер");
              ТБ.НоваяКолонка("Сумма");
              ТБ.НоваяКолонка("ПринятоОт");
              ТБ.НоваяКолонка("ДатаДок");
              ТБ.НоваяКолонка("Основание");
              ТБ.НоваяКолонка("Субконто");        
   Таб=СоздатьОбъект("Таблица");  
   Таб.ИсходнаяТаблица("Таблица");    
   Таб.ВывестиСекцию("Шапка");
    Пока ПКО.ПолучитьДокумент()=1 Цикл
// но если очень много то надо запросом
// дальше писать?
 :wacko:

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
вот люди пошли а? отчет за них напиши, кошмар какой-то,правда мужики?  :trhregerhg:

Оффлайн drwhite

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-20
  • Сайт: 
  • Профессия: Программист 1С
Можно... Пример по строкам отчета:
№     Отделение     Вид платежа    Сумма
 1            А              Пенсия           500
 2            Б             Комуналка      1000
 3            В              Пенсия           800
 4            Г               УТСЗН           300
 5            Д            Комуналка        250

Итого                                          2850
          Та же сумма прописью

Итого: Пенсия 1300, Комуналка 1250, УТСЗН 300

Вот
Меня интересует эта строка: Итого: Пенсия 1300, Комуналка 1250, УТСЗН 300!!!

Оффлайн drwhite

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-20
  • Сайт: 
  • Профессия: Программист 1С
Меня интересует эта строка: Итого: Пенсия 1300, Комуналка 1250, УТСЗН 300!!!

Оффлайн drwhite

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-20
  • Сайт: 
  • Профессия: Программист 1С
"вид платежа" это у нормальных конф. "основание" чтоли?
заполняется вручную или выбирается из списка как то?


из справочника

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Процедура Выполнить()
    ПКО=СоздатьОбъект("Документ.приходныйордер");
   ПКО.ВыбратьДокументы(Дата1,Дата2);

      ТБ = СоздатьОбъект("ТаблицаЗначений");
              ТБ.НоваяКолонка("Номер");
              ТБ.НоваяКолонка("Сумма");
              ТБ.НоваяКолонка("ПринятоОт");
              ТБ.НоваяКолонка("ДатаДок");
              ТБ.НоваяКолонка("ВидПлатежа");
              
   Таб=СоздатьОбъект("Таблица");  
   Таб.ИсходнаяТаблица("Таблица");    
   Таб.ВывестиСекцию("Шапка");
    Пока ПКО.ПолучитьДокумент()=1 Цикл
         ТБ.НоваяСтрока();
         ТБ.Номер = ПКО.НомерДок;
         ТБ.Сумма = ПКО.Сумма;
         ТБ.ПринятоОт = ПКО.ПринятоОт;
         ТБ.ДатаДок = ПКО.ДатаДок;
         ТБ.Основание = ПКО.ВидПлатежа;
       КонецЕсли;
   КонецЦикла;   
          ТБ.Сортировать("ВидПлатежа",);
         ТБ.ВыбратьСтроки();
        Пока ТБ.ПолучитьСтроку() = 1 Цикл       
        Таб.ВывестиСекцию("Строка");
          КонецЦикла;
 
      ТБ.Свернуть("Видплатежа","Сумма");  
      Строка1 = "Итого: ";
      ТБ.ВыбратьСтроки();
      Пока ТБ.ПолучитьСтроку() = 1 Цикл
         Строка1 = Строка1 + " " + ТБ.ВидПлатежа + " " + ТБ.Сумма;
      КонецЦикла;
      Таб.ВывестиСекцию("ИтогПоПлат");
      ИтогоВсего = ТБ.Итог("Сумма");
      Таб.ВывестиСекцию("Итоговсего");
            Таб.Опции(0);
            Таб.Показать();
КонецПроцедуры



// Как то так


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
27 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 163
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal