Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЛЮДИ ПОМОГИТЕ РАЗОБРАТЬСЯ !!!  (Прочитано 1186 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С

Вот пытаюсь разобраться с запросами и выводом информации в табличный документ
помогите начинающему куда собственно вставить запрос и саму процедуру
Ищу в инете примеры пытаюсь разобраться на практике вот что нашла но не пойму в чем ошибка кто подскажет??
Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|          Сотрудники.*
|ИЗ
|   Справочники.Сотрудники КАК Сотрудники
|";
РезультатЗ = Запрос.Выполнить();
ПечатьРезвТаб(ТабДок,РезультатЗ);

//Вых - ЭлементыФормы.РезультатТабличныйДокумент,
//ТЗЗ - Результат выполнения запроса
Процедура ПечатьРезвТаб(Вых,ТЗЗ) Экспорт
   КоличествоКолонок = ТЗЗ.Колонки.Количество();
   Выборка = ТЗЗ.Выбрать(ОбходРезультатаЗапроса.Прямой);
   ДетальнаяСтрока = Вых.ПолучитьОбласть(1, , 1, );
   ОбластьОбщихИтогов = Вых.ПолучитьОбласть(1, , 1, );
   ОбластьОбщихИтогов.Область().Шрифт = Новый Шрифт(ОбластьОбщихИтогов.Область().Шрифт, , , Истина, , ,);
   ОбластьИерархическихЗаписей = Вых.ПолучитьОбласть(1, , 1, );
   ОбластьИерархическихЗаписей.Область().Шрифт = Новый Шрифт(ОбластьИерархическихЗаписей.Область().Шрифт, , , Истина, , ,);
   ОбластьГрупповыхЗаписей = Вых.ПолучитьОбласть(1, , 1, );
   ОбластьГрупповыхЗаписей.Область().Шрифт = Новый Шрифт(ОбластьГрупповыхЗаписей.Область().Шрифт, , , Истина, , ,);
   ОбластьЗаголовка = Вых.ПолучитьОбласть(1, , 1, );
   
   Для ТекущееПоле = 0 По КоличествоКолонок - 1 Цикл
      Область = ОбластьЗаголовка.Область(1, ТекущееПоле + 1);
      Область.Текст = ТЗЗ.Колонки[ТекущееПоле].Имя;
      Область.ШиринаКолонки = ?(ТЗЗ.Колонки[ТекущееПоле].Ширина<3,3,ТЗЗ.Колонки[ТекущееПоле].Ширина);
   КонецЦикла;
   Вых.Вывести(ОбластьЗаголовка);
   ОбластьЗаголовка = Вых.Область(1, 1, 1, КоличествоКолонок);
   
   ОбластьЗаголовка.Шрифт = Новый Шрифт(ОбластьЗаголовка.Шрифт, , , Истина, , ,);
   ОбластьЗаголовка.ЦветФона = Новый Цвет(234, 234, 234);
   ОбластьЗаголовка.ГраницаСнизу = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
   
   Вых.НачатьАвтогруппировкуСтрок();
   Пока Выборка.Следующий() Цикл
      ОбработкаПрерыванияПользователя();
      Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоГруппировке Тогда
         ИсходнаяСтрока = ОбластьГрупповыхЗаписей;
      ИначеЕсли Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоИерархии Тогда
         ИсходнаяСтрока = ОбластьИерархическихЗаписей;
      ИначеЕсли Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ОбщийИтог Тогда
         ИсходнаяСтрока = ОбластьОбщихИтогов;
      Иначе
         ИсходнаяСтрока = ДетальнаяСтрока;
      КонецЕсли;
      
      Для ТекущееПоле = 0 По КоличествоКолонок - 1 Цикл
         Область = ИсходнаяСтрока.Область(1, ТекущееПоле + 1);
         Область.Текст = Выборка[ТекущееПоле];
      КонецЦикла;
      Вых.Вывести(ИсходнаяСтрока, Выборка.Уровень());
   КонецЦикла;
   Вых.ЗакончитьАвтогруппировкуСтрок();
КонецПроцедуры


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5545
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4359
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal