Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 04:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с конфигурацией  (Прочитано 7131 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
Привет всем!!!Подскажите пожалуйста.Вот есть у меня справочник, в нем табличное поле (ДокументСписок), и он никак не хочет отображаться в печатной форме документа (макете). Код программы подобен такому же полю которое отображается..Что делать??


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Видимо, разбираться с "кодом программы, подобным такому дже полю, которое отображается"
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Согласен с Klyacksa. Может код приведете? Тогда будет о чем предметно поговорить

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
Смотрел так же по точкам останова, в той которая отображается все нормально, все шаги проходит по очереди, а в проблемной - цикл перепрыгивает.

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ПечатьСправки(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(ПечатьСправки)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТабДок = Новый ТабличныйДокумент;
   Макет = Справочники.СГГБУ.ПолучитьМакет("ПечатьСправки");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Шапка = Макет.ПолучитьОбласть("Шапка");
   Шапка.Параметры.Заполнить(ЭтотОбъект);
   ТабДок.Вывести(Шапка);
   // Оборудование
   Область = Макет.ПолучитьОбласть("ОборудованиеШапка");
   ТабДок.Вывести(Область);
   ОбластьОборудование = Макет.ПолучитьОбласть("Оборудование");
   Для Каждого ТекСтрокаОборудование Из Оборудование Цикл
      ОбластьОборудование.Параметры.Заполнить(ТекСтрокаОборудование);
      ТабДок.Вывести(ОбластьОборудование);
   КонецЦикла;
   // Обслуживание
   Область = Макет.ПолучитьОбласть("ОбслуживаниеШапка");
   ТабДок.Вывести(Область);
   ОбластьОбслуживание = Макет.ПолучитьОбласть("Обслуживание");
   Для Каждого ТекСтрокаОбслуживание Из Обслуживание Цикл
      ОбластьОбслуживание.Параметры.Заполнить(ТекСтрокаОбслуживание);
      ТабДок.Вывести(ОбластьОбслуживание);
   КонецЦикла;
   // Примечания
   Область = Макет.ПолучитьОбласть("ПримечанияШапка");
   ТабДок.Вывести(Область);
   ОбластьПримечания = Макет.ПолучитьОбласть("Примечания");
   Для Каждого ТекСтрокаПримечания Из Примечания Цикл
      ОбластьПримечания.Параметры.Заполнить(ТекСтрокаПримечания);
      ТабДок.Вывести(ОбластьПримечания);
   КонецЦикла;
   // Подвал
   Подвал = Макет.ПолучитьОбласть("Подвал");
   Подвал.Параметры.Заполнить(ЭтотОбъект);
   ТабДок.Вывести(Подвал);

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ


// Обслуживание
вот проблемная

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
а выше нее Оборудование - вот оно отображается

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Для начала, поставьте точку останова на
Для Каждого ТекСтрокаОбслуживание Из Обслуживание Цикл
и посмотрите, есть ли строки в таблице Обслуживание
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
он сразу перепрыгнул на эту строку :
   Область = Макет.ПолучитьОбласть("ПримечанияШапка");

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Сохраните обработку.
Закройте ее в режиме предприятия, и откройте. Попробуйте еще раз выполнить код.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Shestakov_86

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Программист 8.1
все равно пусто, отображается тоглько шапка таблицы


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1185
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4721
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2448
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3339
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3592
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 156
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal