Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Ноя 2018, 03:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Справочник, изменить запись.  (Прочитано 2269 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, как сохранить изменения в справочнике.
Из формы списка справочника открываю запись и передаю эти данные в обработку форма элементов путем присваивания:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    форма1 = ПолучитьФорму("Обработка.Задача.форма.ФормаЭлемента");
    форма1.открыть();
    Отказ = Истина;
    если  этаформа.Объект.Код <> "" тогда
    форма1.объект.Код=этаформа.Объект.Код;
    форма1.объект.Наименование=этаформа.Объект.Наименование;
    форма1.объект.Номер=этаформа.Объект.Номер;
    форма1.объект.ДатаВремя=этаформа.Объект.ДатаВремя;
    форма1.объект.Автор=этаформа.Объект.Автор;
    форма1.объект.Описание=этаформа.Объект.Описание;
    форма1.объект.Результат=этаформа.Объект.Результат;
    форма1.объект.Срок=этаформа.Объект.Срок;
    форма1.объект.Ключ=этаформа.Объект.Ключ;
    форма1.объект.Уровень=этаформа.Объект.Уровень;
    КонецЕсли;
КонецПроцедуры

На форме обработке пытаюсь сохранить изменения отлавливая команду сохранить.
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    если ЭтаФорма.Объект.Код <> "" тогда
    Отказ=Истина;
    // Вот тут что то нужно написать что бы данные записались по коду записались в ту же запись.
 
    ЭтаФорма.Закрыть();
    КонецЕсли;
   
КонецПроцедуры

Подскажите  код записи в БД для этой ситуации. Или другой способ. Спасибо.


Теги:
 

справочник "Главы по БК"

Автор IaterРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5176
Последний ответ 21 Май 2015, 13:56
от pavl_vs
ЗУП 3.0 справочник "Должности"

Автор denis_ivanovРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2300
Последний ответ 08 Апр 2016, 21:19
от denis_ivanov
Справочник "Ресурсные спецификации"

Автор MroРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1062
Последний ответ 17 Авг 2016, 16:13
от SGIRG
Кнопка "Изменить"

Автор LanniaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 16
Просмотров: 1636
Последний ответ 03 Июн 2017, 01:50
от Dethmontt
Справочник "Сотрудники" можно просматривать

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3958
Последний ответ 03 Фев 2014, 11:50
от Alex56

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
47 Сообщений
alex0402
44 Сообщений
alexandr_ll
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal