Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Справочник, изменить запись.  (Прочитано 2072 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Isandersam

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, как сохранить изменения в справочнике.
Из формы списка справочника открываю запись и передаю эти данные в обработку форма элементов путем присваивания:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    форма1 = ПолучитьФорму("Обработка.Задача.форма.ФормаЭлемента");
    форма1.открыть();
    Отказ = Истина;
    если  этаформа.Объект.Код <> "" тогда
    форма1.объект.Код=этаформа.Объект.Код;
    форма1.объект.Наименование=этаформа.Объект.Наименование;
    форма1.объект.Номер=этаформа.Объект.Номер;
    форма1.объект.ДатаВремя=этаформа.Объект.ДатаВремя;
    форма1.объект.Автор=этаформа.Объект.Автор;
    форма1.объект.Описание=этаформа.Объект.Описание;
    форма1.объект.Результат=этаформа.Объект.Результат;
    форма1.объект.Срок=этаформа.Объект.Срок;
    форма1.объект.Ключ=этаформа.Объект.Ключ;
    форма1.объект.Уровень=этаформа.Объект.Уровень;
    КонецЕсли;
КонецПроцедуры

На форме обработке пытаюсь сохранить изменения отлавливая команду сохранить.
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    если ЭтаФорма.Объект.Код <> "" тогда
    Отказ=Истина;
    // Вот тут что то нужно написать что бы данные записались по коду записались в ту же запись.
 
    ЭтаФорма.Закрыть();
    КонецЕсли;
   
КонецПроцедуры

Подскажите  код записи в БД для этой ситуации. Или другой способ. Спасибо.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 270
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal