Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 05:48

Ошибка: Ожидается ключевое слово 'КонецПроцедуры'

Автор Sariel Kitsune, 12 июн 2019, 12:30

0 Пользователей и 1 гость просматривают эту тему.

Sariel Kitsune

Подскажите пожалуйста, я не понимаю!

Вроде все ; на месте количество Если и Циклов совпадает друг с другом. Я не понимаю откуда ошибка. Подскажите пожалуйста :trhregerhg:


&НаКлиенте
Процедура Расчет(Команда)
Для каждого Урок Из Объект.РасписаниеНаДень Цикл
Если Урок.Мероприятие.Пустая() и
ЗначениеЗаполнено(Урок.ВидУрока) Тогда
Урок.Мероприятие = СоздатьМероприятие(Урок.НомерСтроки-1)
КонецЕсли;
КонецЦикла;


Функция СоздатьМероприятие(ИндексСтроки)

ТС = Объект.РасписаниеНаДень[ИндексСтроки];
НовоеМероприятие = Документы.Мероприятие.СоздатьДокумент();
КодУрока = Число(ТС.НомерСтроки);
Урок = Справочники.ВремяУроков.НайтиПоКоду(КодУрока);
НовоеМероприятие = НачалоДня (Объект.Дата) + (Урок.ВремяНачала-'00010101');
НовоеМероприятие.Номер = "У" + "-" +ТС.НомерСтроки;
НовоеМероприятие.ТипМероприятия = Справочники.ТипМероприятия.Урок;
НовоеМероприятие.ВидМероприятий = ТС.ВидУрока;
НовоеМероприятие.Учитель = ТС.Учитель;
НовоеМероприятие.Записать();
Возврат НовоеМероприятие.Ссылка


КонецФункции


КонецПроцедуры


MuI_I_Ika

Функция не может находиться внутри процедуры. Она должна быть на верхнем уровне модуля.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск