Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2019, 09:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: htpps соединение с отправкой json  (Прочитано 111 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kerbert

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Регистрация: 2017-04-24
  • Сайт: 
  • Профессия: Программист 1С
Нужно поднять https соединение и отправить на него json.
	WinHttp= СоздатьОбъект("WinHttp.WinHttpRequest.5.1"); 
WinHttp.Option(2,"UTF-8");

WinHttp.Open("POST","https://*******:2443/documents/",0); 

WinHttp.SetClientCertificate("localhost");//Что-то в этом параметре

WinHttp.SetRequestHeader("Accept", "application/json");
WinHttp.SetRequestHeader("Content-Type", "application/json");
WinHttp.SetRequestHeader("Accept-Language", "UTF-8");

ТекстJson = "";
WinHttp.Send(ТекстJson);
Но при попытке отправить получаю ошибку:

WinHttp.WinHttpRequest: Для проверки подлинности клиента требуется сертификат

Как я понял проблема в этом параметре WinHttp.SetClientCertificate("localhost").

Может кто объяснит, что туда нужно вставить?

Сертификаты зарегистрированы на локального пользователя.



Оффлайн AIFrame

  • *****
  • Сообщений: 1386
  • РЕПУТАЦИЯ: 177
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Функция СоздатьСоединение(АдресAPI, Порт) Экспорт
ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL;
Соединение = Новый HTTPСоединение(АдресAPI, Порт,,,,5, ?(Порт = 443, ЗащищенноеСоединение, неопределено));

Возврат Соединение;
КонецФункции

Функция ПолучитьЗаголовок_POST(URL) Экспорт
Заголовок = Новый Соответствие();
    Заголовок.Вставить("POST " + URL + " HTTP/1.1");
Заголовок.Вставить("Content-Type", "application/x-www-form-urlencoded");
Возврат Заголовок;
КонецФункции

Функция ВыполнитьЗапрос(Соединение, URL, Заголовок, Тело = неопределено) Экспорт
Запрос = Новый HTTPЗапрос(URL, Заголовок);
Если Тело <> неопределено Тогда
Запрос.УстановитьТелоИзСтроки(Тело);
Возврат Соединение.ОтправитьДляОбработки(Запрос);
КонецЕсли;

Возврат Соединение.Получить(Запрос);
КонецФункции

Оффлайн Kerbert

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Регистрация: 2017-04-24
  • Сайт: 
  • Профессия: Программист 1С
Функция СоздатьСоединение(АдресAPI, Порт) Экспорт
ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL;
Соединение = Новый HTTPСоединение(АдресAPI, Порт,,,,5, ?(Порт = 443, ЗащищенноеСоединение, неопределено));

Возврат Соединение;
КонецФункции

Функция ПолучитьЗаголовок_POST(URL) Экспорт
Заголовок = Новый Соответствие();
    Заголовок.Вставить("POST " + URL + " HTTP/1.1");
Заголовок.Вставить("Content-Type", "application/x-www-form-urlencoded");
Возврат Заголовок;
КонецФункции

Функция ВыполнитьЗапрос(Соединение, URL, Заголовок, Тело = неопределено) Экспорт
Запрос = Новый HTTPЗапрос(URL, Заголовок);
Если Тело <> неопределено Тогда
Запрос.УстановитьТелоИзСтроки(Тело);
Возврат Соединение.ОтправитьДляОбработки(Запрос);
КонецЕсли;

Возврат Соединение.Получить(Запрос);
КонецФункции
Спасибо конечно, но ваш код не подходит в данной ситуации, т.к. он для 8 а не 7. Проблема как раз в реализации на 7.

Оффлайн AIFrame

  • *****
  • Сообщений: 1386
  • РЕПУТАЦИЯ: 177
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
А, сорян. Не обратил внимание.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
61 Сообщений
Yamuna
50 Сообщений
LexaK
43 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
alexandr_ll
21 Сообщений
wise wise
19 Сообщений
AIFrame AIFrame
18 Сообщений
alex0402 alex0402
13 Сообщений
lmlg114@bk.ru
13 Сообщений
Eugeneer Eugeneer
12 Сообщений

* Кто онлайн

  • Точка Гостей: 199
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal