Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Авг 2019, 01:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Себестоимость (цена закупки) в подборе  (Прочитано 136 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ox2net

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
  • Профессия: Ученик 1С
День добрый!

Подскажите или сделайте (не за спасибо) так, что бы в подборе товара при реализации выводилась колонка "Себестоимость". 1с 7.7 ТиС 9


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1079
  • РЕПУТАЦИЯ: 173
  • КПД: 16%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
День добрый!

Подскажите или сделайте (не за спасибо) так, что бы в подборе товара при реализации выводилась колонка "Себестоимость". 1с 7.7 ТиС 9
Чтобы увидеть в подборе одновременно себестоимость и цену реализации следует в конфигураторе в форму списка "Для подбора" справочника "Номенклатура" добавить в табличную часть колонку с текстовым полем, в котором на закладке "дополнительно" указать формулу "
ДатьСебестоимость()
"
В модуле формы добавить функцию примерно следующего содержания:
Функция ДатьСебестоимость()

Если ЭтоГруппа() = 1 Тогда
Возврат "";
КонецЕсли;

Если ПустоеЗначение(ТекущийЭлемент()) = 1  Тогда
Возврат "";
Иначе   
ТекЦена="";
ТЦ=СоздатьОбъект("Справочник.ТипыЦен");
ТЦ.НайтиПоНаименованию("Закупочная");
Б=ТЦ.ТекущийЭлемент();
Ц=СоздатьОбъект("Справочник.Цены");
Ц.ИспользоватьВладельца(ТекущийЭлемент());
Если Ц.НайтиПоРеквизиту("ТипЦен",Б,0)=1 Тогда
ТекЦена=Ц.Цена.Получить(РабочаяДата());
КонецЕсли;
Возврат ТекЦена;
КонецЕсли;
Возврат Стр;

КонецФункции


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
117 Сообщений
alexandr_ll
58 Сообщений
LexaK
47 Сообщений
alex0402 alex0402
45 Сообщений
DmitriyF DmitriyF
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
BuhRust
27 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
18 Сообщений
Андрей_gen_D
16 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal