Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 сен 2021, 14:53

Себестоимость (цена закупки) в подборе

Автор ox2net, 11 июн 2019, 04:18

0 Пользователей и 1 гость просматривают эту тему.

ox2net

День добрый!

Подскажите или сделайте (не за спасибо) так, что бы в подборе товара при реализации выводилась колонка "Себестоимость". 1с 7.7 ТиС 9

alexandr_ll

Цитата: ox2net от 11 июн 2019, 04:18
День добрый!

Подскажите или сделайте (не за спасибо) так, что бы в подборе товара при реализации выводилась колонка "Себестоимость". 1с 7.7 ТиС 9
Чтобы увидеть в подборе одновременно себестоимость и цену реализации следует в конфигураторе в форму списка "Для подбора" справочника "Номенклатура" добавить в табличную часть колонку с текстовым полем, в котором на закладке "дополнительно" указать формулу "ДатьСебестоимость()"
В модуле формы добавить функцию примерно следующего содержания:
Функция ДатьСебестоимость()

Если ЭтоГруппа() = 1 Тогда
Возврат "";
КонецЕсли;

Если ПустоеЗначение(ТекущийЭлемент()) = 1  Тогда
Возврат "";
Иначе   
ТекЦена="";
ТЦ=СоздатьОбъект("Справочник.ТипыЦен");
ТЦ.НайтиПоНаименованию("Закупочная");
Б=ТЦ.ТекущийЭлемент();
Ц=СоздатьОбъект("Справочник.Цены");
Ц.ИспользоватьВладельца(ТекущийЭлемент());
Если Ц.НайтиПоРеквизиту("ТипЦен",Б,0)=1 Тогда
ТекЦена=Ц.Цена.Получить(РабочаяДата());
КонецЕсли;
Возврат ТекЦена;
КонецЕсли;
Возврат Стр;

КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск