Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2019, 10:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подключение через COMОбъект("MSXML2.XMLHTTP")  (Прочитано 104 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ****
  • Сообщений: 395
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Запрос = "<?xml version=""1.0"" encoding=""utf-8""?> <soap:Envelope xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance"" xmlns:xsd=""http://www.w3.org/2001/XMLSchema"" xmlns:soap=""http://schemas.xmlsoap.org/soap/envelope/""> <soap:Body> <Login xmlns=""http://locator.ru/LBS""> <login>" + Логин + "</login> <password>" + Пароль + "</password> </Login> </soap:Body> </soap:Envelope>";

АдресСервиса = "http://locator.ru/api/Security.asmx";//"http://locator.ru/LBS/GetLocations";
//ИмяСервера = "ХТТП_сервак";

MSXML = Новый COMОбъект("MSXML2.XMLHTTP");
MSXML.open("POST", АдресСервиса, 0);
MSXML.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
MSXML.setRequestHeader("Content-Length", СтрДлина(Запрос));
MSXML.setRequestHeader("SOAPAction", "http://locator.ru/LBS/Login");
MSXML.send(Запрос);
ОтветПолучен = Ложь;
Для НомерЦикла = 1 по 100 Цикл
Если MSXML.readyState >3 Тогда
ОтветПолучен = Истина;
Прервать;
КонецЕсли;     
КонецЦикла; 

Если ОтветПолучен Тогда
Ответ = MSXML.responseXML.xml;
КонецЕсли;

Возникает ошибка

Ошибка при вызове метода контекста (send)
   MSXML.send(Запрос);
по причине:
Произошла исключительная ситуация (msxml3.dll): Отказано в доступе.

В чем может быть причина?
Тех поддержка говорит что запрос корректный и работает, а 1С выдает ошибку.


Оффлайн alex0402

  • *****
  • Сообщений: 1860
  • РЕПУТАЦИЯ: 335
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
msxml3.dll

попробовать обновить Microsoft XML Parser
Спасибо за Сказать спасибо

Оффлайн magnifico61

  • ****
  • Сообщений: 395
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2566
Последний ответ 24 Май 2016, 17:17
от Kironten
Обмен УТ 11 и БП 3.0 через универсальный обмен данными

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9182
Последний ответ 25 Дек 2014, 13:40
от cska-fanat-kz
Оплата через терминал - отражение операции и отражение в КУДиР

Автор assol_07Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 5907
Последний ответ 15 Фев 2012, 18:16
от assol_07
Вывод результата запроса через условие другого запроса

Автор jonik_jokerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3647
Последний ответ 16 Окт 2013, 15:08
от jonik_joker
Документы на регистрацию ИП или юридического лица в Московской области можно отправить через фирму DHL Express

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1157
Последний ответ 02 Сен 2014, 12:38
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
61 Сообщений
Yamuna
50 Сообщений
LexaK
43 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
alexandr_ll
21 Сообщений
wise wise
19 Сообщений
AIFrame AIFrame
18 Сообщений
alex0402 alex0402
13 Сообщений
lmlg114@bk.ru
13 Сообщений
Eugeneer Eugeneer
12 Сообщений

* Кто онлайн

  • Точка Гостей: 210
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal