Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 19:11

Подключение через COMОбъект("MSXML2.XMLHTTP")

Автор magnifico61, 10 июн 2019, 18:05

0 Пользователей и 1 гость просматривают эту тему.

magnifico61


Запрос = "<?xml version=""1.0"" encoding=""utf-8""?> <soap:Envelope xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance"" xmlns:xsd=""http://www.w3.org/2001/XMLSchema"" xmlns:soap=""http://schemas.xmlsoap.org/soap/envelope/""> <soap:Body> <Login xmlns=""http://locator.ru/LBS""> <login>" + Логин + "</login> <password>" + Пароль + "</password> </Login> </soap:Body> </soap:Envelope>";

АдресСервиса = "http://locator.ru/api/Security.asmx";//"http://locator.ru/LBS/GetLocations";
//ИмяСервера = "ХТТП_сервак";

MSXML = Новый COMОбъект("MSXML2.XMLHTTP");
MSXML.open("POST", АдресСервиса, 0);
MSXML.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
MSXML.setRequestHeader("Content-Length", СтрДлина(Запрос));
MSXML.setRequestHeader("SOAPAction", "http://locator.ru/LBS/Login");
MSXML.send(Запрос);
ОтветПолучен = Ложь;
Для НомерЦикла = 1 по 100 Цикл
Если MSXML.readyState >3 Тогда
ОтветПолучен = Истина;
Прервать;
КонецЕсли;     
КонецЦикла; 

Если ОтветПолучен Тогда
Ответ = MSXML.responseXML.xml;
КонецЕсли;


Возникает ошибка

Ошибка при вызове метода контекста (send)
   MSXML.send(Запрос);
по причине:
Произошла исключительная ситуация (msxml3.dll): Отказано в доступе.

В чем может быть причина?
Тех поддержка говорит что запрос корректный и работает, а 1С выдает ошибку.

alex0402

Спасибо за Сказать спасибо

magnifico61


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск