Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Июн 2019, 16:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как правильно вывести результат запроса?  (Прочитано 82 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yamuna

  • **
  • Сообщений: 79
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Не получается вывести из запроса данные, в конструкторе все отрабатывает, а здесь не знаю как правильно сделать чтоб итоговый результат получить, подскажите пожалуйста ))
Процедура ТестоваяПроверка()

  //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Спр.Ссылка КАК Ссылка,
| 1 КАК КоличествоУчастников
|ИЗ
| Справочник.КабинетНачинающихКлиентов КАК Спр
|ГДЕ
| НЕ Спр.Родитель = ЗНАЧЕНИЕ(Справочник.КабинетНачинающихКлиентов.ПустаяСсылка)
| И Спр.Родитель В ИЕРАРХИИ(&Родитель)
| И НЕ Спр.ПометкаУдаления
|
|СГРУППИРОВАТЬ ПО
| Спр.Ссылка
|ИТОГИ ПО
| Ссылка ТОЛЬКО ИЕРАРХИЯ";

Запрос.УстановитьПараметр("Родитель", Рефер);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаСсылка = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
ИтогКОлич = 0;
Пока ВыборкаСсылка.Следующий() Цикл
// Вставить обработку выборки ВыборкаСсылка

ВыборкаДетальныеЗаписи = ВыборкаСсылка.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

ИтогКОлич = ВыборкаДетальныеЗаписи.КоличествоУчастников;

КонецЦикла;
КонецЦикла;


Сообщить("У "+ВыборкаДетальныеЗаписи.Ссылка+" - "+ВыборкаДетальныеЗаписи.КоличествоУчастников);

КонецПроцедуры


Оффлайн AIFrame

  • *****
  • Сообщений: 1386
  • РЕПУТАЦИЯ: 177
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Жесть какая-то.
	Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| СтруктураСети.Ссылка КАК Ссылка,
| СУММА(ВЫБОР
| КОГДА СтруктураСети.ЭтоГруппа = ИСТИНА
| ТОГДА 0
| ИНАЧЕ 1
| КОНЕЦ) КАК Количество
|ИЗ
| Справочник.СтруктураСети КАК СтруктураСети
|
|СГРУППИРОВАТЬ ПО
| СтруктураСети.Ссылка
|ИТОГИ
| СУММА(Количество)
|ПО
| ОБЩИЕ,
| Ссылка ТОЛЬКО ИЕРАРХИЯ";
ЗначениеВРеквизитФормы(Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией), "Древо");


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 15027
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Как правильно настроить регламентные "Обновление индекса ППД" и "Слияние индекса ППД"

Автор bkmz_1_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8777
Последний ответ 13 Окт 2016, 09:14
от MuI_I_Ika
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 5666
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 2864
Последний ответ 15 Июн 2017, 07:53
от mvk843
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1096
Последний ответ 29 Май 2017, 15:29
от alex0402

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
62 Сообщений
Yamuna
46 Сообщений
LexaK
42 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
AIFrame AIFrame
18 Сообщений
wise wise
16 Сообщений
alex0402 alex0402
15 Сообщений
lmlg114@bk.ru
13 Сообщений
alexandr_ll
12 Сообщений
ab30ru
11 Сообщений

* Кто онлайн

  • Точка Гостей: 531
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal